SDK fails to run the project

what coud be the possible causes for SDK to succesfuly set up a server , succesfully create a project , but fails to run the project.

What is your error message?

1 Like

  1. Your project does not build due to an error with org.openmrs.module.displaydata.api.dao.DisplayInfoDao the file

  2. Try running mvn clean install on your project

1 Like

i tried that and it still failed

Tried what that failed? More information is always helpful otherwise I cannot understand what is going wrong on your project

1 Like

@mozzy can you take a look at this?

And this? Short description of how to ask a question well?

1 Like

oh, i meant i tried the mvn clean install and the error persisted

Hi @mozzy, have you tried to investigate the error yourself? Often, knowing where to look in the logs/stacktrace and some smart googling can help solve your issues, without needing a deep understanding of OpenMRS. When this still doesn’t help to solve your problem, you can at least let the community know the steps you’ve taken to try and solve the issue yourself, so that they don’t spend time repeating those steps when helping to troubleshoot. For example, looking at your stacktrace:

The first ERRORs start appearing from line 266. On line 268, there’s an error message that ends with:

–Dplatform.jar; error in opening zip file

Googling this error, the first search result is a link to this post on StackOverflow:

The responses in that post suggest the issue may be related to corrupted files or download issues in the local .m2 Maven repository, and suggest either:

  • Running mvn -U clean install (The -U parameter forces maven to update), or
  • Removing your local /.m2/repository/ and then running mvn clean install to download the files again.

I’m not sure if either of those solutions would fix the issue you’re facing, but may be worth trying as a first step.

1 Like

thx @danfuterman… well the only steps i tried out was running mvn clean install but i still got the error,

i also tried deleting the m2/repository and wen i updated maven again, i still got the same error. let me try the u clean install…thx

here is the error log after running mvn -U claen install

it has finaly built SUCCESSfuly, and it has compiled the omod jar file, but there are errors with in the project its self that "the import can not be resolved "

example “The import org.apache cannot be resolved”,

“The import org.openmrs.module.BaseModuleActivator cannot be resolved”

“The import org.hibernate cannot be resolved”

“The import org.springframework cannot be resolved”

yet it has built succesfully with mvn clean install @dkayiwa @danfuterman @ssmusoke

1 Like

Have you got a chance to read some beginner Java books?


well , al those classes missing out , all the jars are actually there, may be they are just corrupted

It’s unlikely that the jars are corrupted, and more likely related to a build path / compiler discrepancy. To be clear, the last example was simply to show a process you might consider taking to help you find answers to general technical issues outside the Talk forum. In this case, I’d suggest the same - have you tried to google The import ... cannot be resolved, and were there any search results that indicate what the cause of the issue might be? And if so, were there any suggestions or solutions that you tested, or anything that helped you to understand the issue better?

1 Like

well, the solution they give me from google is to remove those jars from the m2/repository, and update maven again…