Order entry ui owa issues

Hi folks at @Andela UG, thanks for the work done at: https://github.com/openmrs/openmrs-owa-orderentry Just tried out deploying the owa into my local Reference application and had a number of unclear issues.

What i have done:

  • Downloaded the latest owa from: https://addons.openmrs.org/ and installed it
  • I added an encounter type and mapped its name to orderentryowa.encounterType setting
  • I added an encounter role that i mapped by name to orderentryowa.encounterRole setting
  • When i ran i was upset by:
  • Made me get confused which property naming is being used, whether order.* or orderentryowa.*!!!
  • I therefore added both naming conventional setting for encounterType and had a completely unclear error, not sure what incomplete settings implies. can someone help out clarify things. I completely think this will bring similar confusion to other users.

Questions:

CC: @dkayiwa.

Are you able to reproduce this problem on using the owa attached on this ticket? https://issues.openmrs.org/browse/OEUI-163

i loaded that owa attached a week ago but had the same issue as seen in the last screenshot

Can you refresh your browser cache? Or use a new Incognito window?

even worse:

will investigate as soon as i have time

Hi everyone,

@k.joseph I have a feeling that the error you are getting above may be from an older version of the file. I have updated the file on bintray. Please take time to re-download and try again. As for what “incomplete config” could mean, I will suggest you check this.

I will also like to note that the team made some changes to the web rest module and a couple of other modules which has not been released yet. I will suggest you build an omod from their master branches and update your existing versions. Please find more information here

Thanks and sorry for the inconvenience this may have caused.

cc @dkayiwa

One reason why you would get this error is if the file you downloaded was a copy of the openmrs-owa-orderentry.zip file e.g openmrs-owa-orderentry (1).zip or something else. What this means is that rather than having the url above as your app’s correct url, you will actually have this instead http://localhost:8082/openmrs-standalone/owa/openmrs-owa-orderentry%20(1)/index.html

Overall, check the file you downloaded to be sure the filename is as stated above. Thanks

did u say u have updated it? i just re-tried out https://dl.bintray.com/openmrs/owa/1.0.0-beta/openmrs-owa-orderentry.zip and got the exact same issue. as far as i know, https://addons.openmrs.org/#/show/org.openmrs.owa.orderentryui contains no reference to “incomplete config”, anyways, i plan to checkout the code as soon as i need to use up your work

about the file, i hope http://localhost:8081/openmrs-standalone/owa/openmrs-owa-orderentry/index.html?patient=9b76e4b5-2198-462c-8171-43f8f476d380 is pretty a clean url of your expectations !!! so, the file name makes no difference in the url loaded

Actually it does, when you download the file from bintray or other links and the file already exists in that location, the downloader appends a (1) to the filename (at least on mac). Your refApp in turn uses this filename to create the url for the app.

Please navigate to System admin -> Advanced Admin -> Open Web Apps Module (Mange Apps) -> then click the order entry and confirm the url matches expected.

can you create a ticket to fix that behaviour in https://github.com/openmrs/openmrs-module-owa!!!

I just tested the app now and it worked for me. Have you updated the web rest module as suggested? See here

I am not sure this is an issue with the order entry app itself. This is more of an issue with the native file downloader/reference application.

I will suggest you do the following

  • Check this guide on setting up the configs
  • Hard reload the application or open in incognito mode
  • Navigate to System admin -> Advanced Admin -> Open Web Apps Module (Mange Apps) -> then click the order entry. Copy the url
  • Paste the above url into a new tab and append ?patient=patient_uuid

You may also find this link and this one helpful

Thanks.

this was helpful, i built https://github.com/openmrs/openmrs-module-webservices.rest/tree/master skipping tests since they were failing (CC: @dkayiwa) to have it successful and got it installed which fixed things. I suggest you mention this in your documentation @larrystone or someone else from @Andela UG

see: https://issues.openmrs.org/browse/RESTWS-707

thanks

Glad to know that helped. It was stated in the docs. Check here and here for more info

Hello I am newbie to OpenMRS, would appreciate immediate step in from team members. I tried to upload orderentryui from the link below https://addons.openmrs.org/#/show/org.openmrs.owa.orderentryui

And follow all the steps mentioned in https://wiki.openmrs.org/display/projects/Order+Entry+UI+Administrator+Guide

I am having errors, "Configuration for orderentryowa.encounterRole is incomplete. Please contact your administrator for more information.

As an Administrator, please ensure that you have created a valid encounter role ."

@tunmi @topseysuave @efosa @rhenshaw56 @jeiddiah can you help here?

Hi @dailyshelter,
Did you update the web rest module as stated here?

Can you use the rest webservices module attached on this ticket? https://issues.openmrs.org/browse/RESTWS-706