Exception when Installing OpenMRS Reference app

Your tomcat instance is not pointing to Java 8

How can i do this?

Thank you so much. I do this and everything works. I create a service for tomcat with a bad jdk reference. Thank you so much.

But i dont see pharmacy module in. I am talking about Dispensing Medication

cc @gcliff @herbert24

@wdessin you may not exactly see that concept name specifically though functionality of the modules may be similar.RA have got lots of modules, so what exactly are you try ing out with the reference application

I want to add Dispense medication module in RA. I am a java developer too…

I want: 1- Register patient 2- start visist 3- collecte vitals signs 4- take consult notes 5- dispense medication 6- collect allergy 7- manage appointment 8- etc… 9- close visit

@wdessin i actually try to follow your procedures but seems am getting lost, can you please show us the direction and expectations, or else if you have tried share the screen shots , it may be so helpfull thanks

When i install RA i don’t have this.

But i install it using the omod file.

when trying to access it i get this error: https://pastebin.com/2Zj1t2nK

Can you point us to where you got this omod file?

https://addons.openmrs.org/show/org.openmrs.module.dispensing-module

When you check the manage modules page, is the module started and running? Can you share a screenshot?

Hello team. I’m facing similar challenges as the intiator. Don’t know why the progress stopped but I need help. Following the conversation with @dkayiwa to your last enquiry: is the module started and running? Yes. My module ver is 1.1.0, ref app 2.10…, enterprise 2.3. All other dependences are ok. I’ll please need a heading. Thanks

Can you share the server side log via pastebin.com?

Morning, here goes the URL of the server side log: https://pastebin.com/cPbz4M01 here goes the error generated by clicking the dispense medication on the home page:https://pastebin.com/Mutw8vL2 additionally; I followed some instructions from Order Entry UI Administrator Guide. so far I’ve exhausted it. yet, the errors. cant figure out where I’m getting it wrong. I’ve attached also attached a screen shot of the error generated when prescribed medication is clicked

Is this thread of help? Order entry ui owa issues

Will go thru it and revert pls.

Thanks, It worked. But I noticed the return button not working and returns an error. Also my actions option on the orders lists isn’t working. Then my lab order shows as in the screen shot and that’s it. Nothing. What am I doing wrong this time?

I’ve attached images to show for.

Is this helpful for the return button? Order entry UI Return button not working