GSOC 2019 : UI For Reset Password via Email Project

gsoc
gsoc2019
Tags: #<Tag:0x00007fdb1b611e28> #<Tag:0x00007fdb1b611ae0>

(Tendonge Awo-Nasako Ryan) #1

Hello @harisu @madushan , my name is Tendonge Ryan, a final year computer engineering student of University of Buea, Cameroon. I have a good knowledge of Java, HTML, CSS, REST, Spring, MySQL and Angular 5 and basic knowledge of python and javascript. I was accepted for gsoc 2018 with LibreHealth( whose code base is basically a modified fork of OpenMRS core) and also i work part time with PetherSolutions, a company based in Douala, Cameroon, whose Hospital Management System is built on OpenMRS core and Reference Application, so I have an extensive knowledge of OpenMRS.

I have followed carefully the discussions on the discussion thread for this project for the gsoc 2018 session and I would be very much interested in carrying on with it this year. I did not find any issues for this project on OpenMRS jira, so I would like to know how to proceed from here.


(Daniel Kayiwa) #2

Did you first of all run and test the changes which were done for the first phase during GSoC 2018?


(Tendonge Awo-Nasako Ryan) #3

I did not at the time. I just went through the project discussion thread for this project for the gsoc 2018 session, and then read the final presentation thread and also watched the final presentation. But on trying to test, I did notice one thing. When creating a user, how do you attribute a an email to him? I had overlooked that when watching the video, but on trying to test, I can’t figure out how it was done.

Also, I keep getting a request 404 error even when I make the request using the username of a user that exists in my system.


(Daniel Kayiwa) #4

Which versions of the OpenMRS Platform and REST webservices module are you running?


(Tendonge Awo-Nasako Ryan) #5

For REST webservices, I’m running version 2.25.0-SNAPSHOT.5baac6. And I’m running running Reference Application 2.8.1


(Daniel Kayiwa) #6

According to this TRUNK-5425 you need to upgrade your war file to platform 2.2


(Saurav Jaiswal) #7

@dkayiwa My name is Saurav Jaiswal from India ,and I am eager to get involved in the openMRS community for GSoc; the android related projects especially caught my eye. I have experience in android app development and some in web development as well. I am well into my academic career as a Computer Science student and know that my programming skills would be of great use in these projects.This is my first time interaction with open source community and also in GSoc. I am very eager to contribute in OpenMRS project as to serve in helping the saving lives.

I look forward to working hard for the openMRS community! Thanks for this opportunity


(Tendonge Awo-Nasako Ryan) #8

Hi @dkayiwa, sorry about the late reply, been busy with my midsems. I upgraded my platform to 2.2.0-beta, and i later even created a new server altogether using the sdk, and created a platform still with version 2.2.0-beta. On both cases, the rest calls keep failing with a 404 error. So I checked the Rest API documentation and there is no documentation there for a passwordreset resource.

@harisu could you please point me in the righ direction? Maybe I am doing something wrong. I am following the steps you highlighted in the youtube video of your gsoc 2018 final presentation.


(harisu fanyui) #9

@saurav Welcome great to know you are interested in doing GSoc with OpenMRS . I am confused to whether you are interested in this project or the android client which you made mentioned of in your post.


(harisu fanyui) #10

@ryan97, welcome you are using a get request for requesting for a password reset its supposed to be a post request. Surely the reason why your are getting the error. And part of the task for this project is providing that field for creating email during creation of a user if you read well the description. But as at now you can test that using phpmyadmin or the raw mysql command line client to add an email to a user you have created.


(Saurav Jaiswal) #11

Sir I am interested in working on Nigerian Telemedicine app on this GSoc.


(harisu fanyui) #12

@saurav, This thread is for UI For Reset Password Via Email Project. you can find the discussion for Telemedicine app here Nigeria Telemedicine App Project.


(Saurav Jaiswal) #13

Sir actually I am interested on both the projects Nigerian telemedicine app and UI for reset password via email. @harisu fanyui


(Tendonge Awo-Nasako Ryan) #14

Hi @harisu, for some reason I still keep getting the 404 error for the rest call

That is a screenshot of my test and its results. Again, I checked the REST API documentation, but couldnt find any passwordreset resource. I am using openmrs war 2.2.0-beta(I believe it is the latest platform edition)


(harisu fanyui) #15

@ryan97, Can you verify that there is a field activation_key on the user table and has a value after attempt in resetting a password via that endpoint?. You can check out how to run the changes for the passwordreset via email here. https://wiki.openmrs.org/pages/viewpage.action?pageId=216367317. For the part where you didn’t see the passwordreset resource, It is because there is actually none. You should instead see a passwordreset controller.


(Tendonge Awo-Nasako Ryan) #16

Hi @harisu, Yes there is an activation_key field in the users table and I’ve followed all the steps in the wiki page you pointed out but I still get the 404 error. The activation key field keeps having the value NULL. I have the latest openmrs war version and also the latest code for the web services module. I don’t know what I am doing wrong


(harisu fanyui) #17

I seem not to be having issues locally Let me delete the code base I have and try to start all over to see if I can reproduce the error.


(Tendonge Awo-Nasako Ryan) #18

Sounds good. You could even start by creating a new platform using the SDK, creating a new database and work from there. That should do it


(harisu fanyui) #19

@ryan97 Can you verify to make sure that you can access any other resource via the webservice that you installed, like maybe creating a person just something trivial?. You can check how to do that here https://wiki.openmrs.org/display/docs/Create+Patient Let me know if it works.


(Tendonge Awo-Nasako Ryan) #20

@harisu what I did was, I deleted all my servers, then created a new platform using the SDK setup command, chose the latest platform version(2.2.0-beta) and once that was set up, I made sample rest calls which were a success. But I still got the 404 error when testing with the password reset call. So I then pulled in the latest code from the rest web services module, built and deployed to my server, and that seemed to do the trick

But now, after I run the initial POST request to passwordreset, I get an internal server error. But when I check my database, the activation_key value for that particular user has been set.

That is a screenshot of the error message I got