Beta release - 0.92 (Platform upgrade + odoo integration)

bahmni
releases
Tags: #<Tag:0x00007fbad4e1ff00> #<Tag:0x00007fbad4e1fdc0>

(Rajashri Khobragade) #1

Hello All,

Beta release for bahmni 0.92(Centos 7) - Platform upgrade is out Whats new?

  • Odoo10 integration
  • Nagios upgrade to 4.3

From Alpha

  • Bahmni on centOS7
  • Mysql upgrade to 5.7
  • Postgres upgrade to 9.6
  • Apache upgrade to 2.4

Updated password for openmrs, reports and atomfeed and root mysql users can be found here. For details visit jira card

The following links are available for you to do QA and UAT:

  1. https://product-qa08.mybahmni.org
  2. Bahmni connect
  • PWA on chrome: you can launch Connect from the home screen of the environments mentioned above.
  • Android: you can download apk from here . On startup, you will need to specify the server Hostname/ IP address. For example: product-qa08.mybahmni.org

The credentials are

  1. EMR : superman/Admin123
  2. ELIS (Lab): admin/adminADMIN!
  3. dcm4chee: admin/admin
  4. Connect: superman/Admin123 (login to location SEM or GAN)
  5. ERP (Odoo): admin/admin

Local Bahmni Setup

If you would want to run and try Bahmni locally, please follow the steps to download and install this release candidate on CentOS 7.4 onwards:

  1. Download latest bahmni installer (check the thread below for notification on latest installer availability)

wget http://repo.mybahmni.org.s3.amazonaws.com/rpm/bahmni/bahmni-installer-0.92-76.noarch.rpm

  1. Install bahmni installer

sudo yum install bahmni-installer-0.92-76.noarch.rpm

  1. create setup.yml configuration file. See [here ]

curl -L https://gist.githubusercontent.com/rajashrik/2765187385ce9b59b6dd1d6a9f6be52b/raw/14ba764f822372443792a0a8f0f1045a2d980055/setup.yml >> /etc/bahmni-installer/setup.yml

  1. Point the bahmni_base_url to amazon s3. You need to add line below in setup.yml for this

bahmni_repo_url: http://repo.mybahmni.org/rpm/bahmni

  1. Modify the inventory file if needed and run the installer

bahmni -i local install

Let Core team know if any feedback through following channels -

  1. Talk thread : We will use this thread for anything posting relevant to the release - Updates and notifications from the release team, reporting new issues (new JIRA cards only) etc
  2. Slack : #community channel for regular discussions. Please see here for details

@ajeenckya, @angshuonline, @arjun, @darius, @ivange94, @krishnanspace, @mksd, @mksrom, @nehagupt, @pramidat, @ramashish, @ramses, @shilpa, @shivarachakonda, @snehabagri, @sruti, @swathivarkala, @vmalini


Need help in testing Odoo app integrated with Bahmni (0.92 alpha release)
(Ramashish Joshi) #2

While installing on AWS we got error in Task atomfeed-console

2019-04-05 02:14:41,004 p=12988 u=root |  An exception occurred during task execution. To see the full traceback, use -vvv. The error was: TypeError: 'str' object is not callable
2019-04-05 02:14:41,010 p=12988 u=root |  failed: [localhost -> localhost] (item={u'group': [u'localhost'], u'db': u'bahmni_pacs', u'schema': u'public'}) => {"changed": false, "item": {"db": "bahmni_pacs", "group": ["localhost"], "schema": "public"}, "module_stderr": "Traceback (most recent call last):\n  File \"/tmp/ansible_fdmAJf/ansible_module_postgresql_privs.py\", line 673, in <module>\n    main()\n  File \"/tmp/ansible_fdmAJf/ansible_module_postgresql_privs.py\", line 662, in main\n    msg = to_text(e.message(encoding=conn.encoding))\nTypeError: 'str' object is not callable\n", "module_stdout": "", "msg": "MODULE FAILURE", "rc": 0}
2019-04-05 02:14:41,055 p=12988 u=root |  	to retry, use: --limit @/opt/bahmni-installer/bahmni-playbooks/all.retry


(Himabindu Akkinepalli) #3

@ramashish Thanks for trying out the beta release. Could you please confirm that you are installing Pacs module as part of bahmni installation ??


(Ramashish Joshi) #4

Yes we are installing full Bahmni including pacs and dcm4chee.


(Himabindu Akkinepalli) #5

@ramashish Thanks for confirming. we are looking into the issue and we will get back to you with updates


(Himabindu Akkinepalli) #6

@ramashish We have installed bahmni-installer-0.92-76 on my local machine with both pacs and dcm4chee modules and the entire installation has passed for us. We don’t see any issue. Could you please re-trigger the installer once. Do let us know if you still face the issue. Thanks !


(Ramashish Joshi) #7

When I tried with Ultraserve CentOS 7.4 community AMI I got this error while installing the installer - Error: Package: bahmni-installer-0.92-76.noarch (/bahmni-installer-0.92-76.noarch)

Requires: epel-release
Error: Package: python-devel-2.7.5-58.el7.x86_64 (ultra-centos-7.4-base)
       Requires: python(x86-64) = 2.7.5-58.el7
       Installed: python-2.7.5-68.el7.x86_64 (installed)
           python(x86-64) = 2.7.5-68.el7
       Available: python-2.7.5-58.el7.x86_64 (ultra-centos-7.4-base)
           python(x86-64) = 2.7.5-58.el7

(Ramashish Joshi) #8

So tried again using CentOS 7.6 but got the same error for PACS.


(Ramashish Joshi) #9

Please note that the CentOS 7.6 image that I got does not allow to login as root so I have to login as a default user. But before bahmni installation I did sudo su.

Will that be the reason for this error?


(Angshuman Sarkar) #10

I doubt that. Can you try with any other? e.g. https://aws.amazon.com/marketplace/pp/B00O7WM7QW


(Himabindu Akkinepalli) #11

yes… @ramashish We checked Ultraserve CentOS 7.4 AWS image and this doesn’t have basic CentOS-Base.repo and this is the reason why its not able to download the dependent rpm’s. We suggest people to use official CentOS image to test the installer.

will check this specific scenario and get back to you.


(Himabindu Akkinepalli) #12

@ramashish we have tried bahmni-installer-0.92-76 on CentOS 7.6 vagrant box and ran the bahmni -i local install command as sudo user and installation has passed without any issues. Please let us know if you need more details.


(Angshuman Sarkar) #13

So did I. I used default centos/7 box. I had to install wget, but rest of the installation worked out smooth.


(Angshuman Sarkar) #14

I just started checking the Odoo integration. Wanted to report a few things

  • Couldn’t find a easy way to define “currency”. I had to go to Settings => Companies => My Company => and then click this small link mentioned in the notes (Activate [here] a new currency before creating a new company) => Then activate the appropriate currency.

    Is there an easier path to do so?

  • I didn’t find any place under accounting to defined “fiscal year” and “Periods” like openerp? Is this not required? How will this effect reporting or other accounting aspects? In OpenERP not defining fiscal year and periods would throw up error during “Sale order” creation. Now it does not. So I don’t even know what repercussions it will have.

  • Default currency set is “Euro”? It used to INR.

  • No default shop like OPD, IPD, Pharmacy like before

  • seeing different with old quotation list view - like Provider, Discount Head, Care Setting, Village (or other address attribute), total outstanding (although outstanding I am not sure how its used)

  • Product by categories - can’t find product by categories listing

  • The categories themselves are different. It should have same hierarchies like older ERP.

(Moved this to this thread)


(chine zoheir) #15

While installing bahmni 0.92 on docker container (based on centos:7 image) i got the following error: https://hastebin.com/evetujihuq.sql

is there any additional step or different options for installation using docker ?

Cc: @mksrom


(Tapologo Zachariah) #16

I ran into below error while running the installer

TASK [bahmni-base : Install ntp] ************************************************************************************************************************************************************ task path: /opt/bahmni-installer/bahmni-playbooks/roles/bahmni-base/tasks/main.yml:18 fatal: [localhost]: FAILED! => {“changed”: false, “msg”: “Failure talking to yum: failure: repodata/repomd.xml from bahmni: [Errno 256] No more mirrors to try.\nhttp://repo.mybahmni.org/rpm/bahmni/repodata/repomd.xml: [Errno 14] HTTP Error 403 - Forbidden”}

Contents of my setup.yml

timezone: Africa/Gaborone implementation_name: default selinux_state: disabled bahmni_repo_url: http://repo.mybahmni.org/rpm/bahmni


(Angshuman Sarkar) #17

Seems like the repo was down. Have you tried it again?


(Angshuman Sarkar) #18

Whats the dockerfile you used? We had systemd issues as well.

Check also this thread

@binduak anything strikes a chord here?


(Tapologo Zachariah) #19

I will try it again later


(Ramashish Joshi) #20

Has anyone tried it on AWS? If so which particular CentOS image was taken?