Announcing Bahmni 0.92 Release Candidate

Hi, @angshuonline I have tested Editing OpenELIS Panels - #4 by stephencoduor is still an issue even with version 0.92-120 is there a work around

I have attached the csv for the HVS sample and HVS department concept and concept sets for those who want to reproduce

Hvs_Department_concepts.csv (2.5 KB) Hvs_Department_concept_sets.csv (743 Bytes) HVS_sample_concepts.csv (3.6 KB) HVS_sample_concept_sets.csv (1.2 KB)

@angshuonline Faced same error “JQuery not defined” and followed your solution, now getting an error “Uncaught TypeError: this.$…).destroy is not a function after logging in Odoo”.

Please try with the latest installer version:

Dear All, A new new build of 92 is available at our S3 repo:

We are very close to releasing 0.92. Soon :slight_smile:

The same build is also available at

Dear All,

A new version of 0.92 is available at our S3 repo. (v 0.92-140)

The instructions for installation remain the same (check the first post on the thread)

The same build is deployed and configured at our QA08 env.

Few products like “Ibuprofen 400 mg” & “Albendazole 200mg” is also configured accordingly for you to test out.

The “Odoo configuration” document has been updated for medication dispensing scenarios. “Community Feedbacks” tracked through the Excel Sheet is also updated. Please test out your respective reported issues (either installing on your local env or on QA08 env)

Thanks for participating in the community QA process. We hope to do public release very soon, unless anything major/blocker is reported.

@arjun @mksrom @ramashish @sushilp @laxman @dipakthapa @sanjayap @stephencoduor @zouchine


Hey guys! been searching through the forum, May I know

  1. How can I export all patient data from bahmni

  2. How can I upgrade from version 0.92-93 to v 0.92-140

  1. Depends on what you want to export and in what form. Look at these pages for exports

    If you want just to take a backup - then you can look here


1 Like

Thanks @angshuonline, sorry I was not clear, what I wanted is how to export encounters for all the patients from bahmni.

ie all clinical information about the patient: observations, diagnosis, lab order/results and drug orders.

I can only see the information on how to import from Migrate+Patient+and+Encounter+Data

Kindly your help

Is there any problem in purchase vendor bill entry form. First time created bill was fine and journal entry was also seen for the same. Similarly i made second entry and while validating it throw the error “Record does not exist or has been deleted.” . Is there some configuration that i am missing. Please help me out of this.

I’m trying to restore into openelis using below command ( I Uninstalled Backup Tools)

bahmni -i local restore --restore_type=db --options=clinlims --strategy=dump --restore_point=clinlims_dump_20181130-225806.sql.gz

But i get this error

TASK [pgbackrest-restore : Start PostgreSQL] *********************************************************************************************************
task path: /opt/bahmni-installer/bahmni-playbooks/roles/pgbackrest-restore/tasks/pgsqldumprestore.yml:6
fatal: [localhost]: FAILED! => {"changed": false, "msg": "value of state must be one of: started,stopped,restarted,reloaded, got: running"}

TASK [pgbackrest-restore : Drop clinlims database] ***************************************************************************************************
task path: /opt/bahmni-installer/bahmni-playbooks/roles/pgbackrest-restore/tasks/pgsqldumprestore.yml:12
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: 	connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?
fatal: [localhost]: FAILED! => {"changed": false, "msg": "unable to connect to database: could not connect to server: No such file or directory\n\tIs the server running locally and accepting\n\tconnections on Unix domain socket \"/var/run/postgresql/.s.PGSQL.5432\"?\n"}
	to retry, use: --limit @/opt/bahmni-installer/bahmni-playbooks/incr-postgresdbrestore.retry

PLAY RECAP *******************************************************************************************************************************************
localhost                  : ok=9    changed=0    unreachable=0    failed=1

where did you place your dump file? please check your path. Also how did you created this dump file of elis only?

Can i choose to only import Customer, Supplier and Products for V7 to V10? because i will want to keep Quotations and invoices in V7 for references and start afresh with V10 but i will need the Names of patients, Lab and Drugs to match what is in openmrs so that an order can sync.

Also after importing will the data from V7 (Customers, Suppliers, Product) replace what is already in V10 or it will add-up?

I placed the dump file at var/lib/pgbackrest/clinlims folder

and also i created the dump file using this command for openlis which worked:

bahmni -i local backup --backup_type=db --options=clinlims

But then also command for openerp/Odoo didn’t create any backup folder like it usually do on Bahmni 0.91

bahmni -i local backup --backup_type=db --options=openerp

Hi Team, I am using v 0.92-142.noarch.rpm Whenever i change the product Category from the

> Inventory->Configuration->Product Category

ie rename the pre-configured categories the atomfeed stops working and cant get quotations

what might be the solution, I want to have products categorized by their location ie pharmacy, Lab service , Dental service , Maternity etc and not lab panel, Lab Test, injection, Lotion, Drop See attached me2

I can’t login mysql through Terminal any help?

[root@localhost ~]# mysql -uroot -ppassword openmrs
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Try username : root password: P@ssw0rd

1 Like

This must correspond to the members of “Dose Quantity Units” in OpenMRS concept dictionary. Also, please don’t change the parent hierarchy, “All/Services/lab”, “All/Saleable/Drugs” etc

1 Like

I am trying to install bahmni 0.92 in vagrant centos but getting following error

fatal: [localhost]: FAILED! => {“changed”: false, “msg”: “Unable to start service openmrs: Job for openmrs.service failed because a configured resource limit was exceeded. See “systemctl status openmrs.service” and “journalctl -xe” for details.\n”}

can anyone suggest the solution ?

What configuration is your server? most like resources are issue - diskspace, memory etc.

Configuration of my machine is as follows:

total           used        free      shared  buff/cache   available

Mem:       12G        2.9G        8.8G         36M        934M        9.4G

Swap: 2.0G 0B 2.0G

/dev/sda1 40G 8.7G 32G 22%

devtmpfs 6.3G 0 6.3G 0% /dev

tmpfs 6.3G 4.0K 6.3G 1% /dev/shm

tmpfs 6.3G 8.7M 6.3G 1% /run

tmpfs 6.3G 0 6.3G 0% /sys/fs/cgroup

tmpfs 1.3G 0 1.3G 0% /run/user/1001

bahmni 134G 96G 38G 72% /bahmni

tmpfs 1.3G 0 1.3G 0% /run/user/1000