Announcing Bahmni 0.92 Release Candidate

Hey I get Bahmni addons error on Centos 7.6 .

2019-07-06 11:22:45,243 17740 ERROR odoo odoo.modules.registry: Model atom.event.worker has no table.

2019-07-06 11:22:45,305 17740 ERROR odoo odoo.modules.registry: Model order.save.service has no table.

2019-07-06 11:22:45,305 17740 ERROR odoo odoo.modules.registry: Model reference.data.service has no table.

2019-07-06 11:22:45,306 17740 ERROR odoo odoo.modules.registry: Model product.uom.service has no table.

2019-07-06 11:22:45,306 17740 ERROR odoo odoo.modules.registry: Model drug.data.service has no table.

Detailed error here pastebin

The above should not stop Odoo or Clinical-ERP functions. We will fix the error reporting. Thanks.

@stephencoduor What exactly is the error you are facing?

  • do you find that your odoo is running, but the menus not loading?
  • if yes, can you check for any error reported on browser console (or use chrome devtools to check)?
  • Do you see error like “JQuery not defined” etc?

If yes, try this:

  1. Stop Odoo

service odoo stop

  1. Check the database for ir_attachments table entry
> psql -Uodoo
> select id, create_date, store_fname, datas_fname from ir_attachment where datas_fname like '%.js%';
  1. Delete records that you found like “web.assets_*.js” from ir_attachments table.

delete from ir_attachments where id in (… , … )

  1. Restart Odoo

service odoo restart

  1. Open Odoo on browser and check

Thanks @angshuonline for your quick reply, here is what happened, The installation process went on smoothly and all was running smoothly. then suddenly odoo stop when I try to start odoo I get the error below

[root@meds stephen_otieno]# sudo service odoo start Starting odoo (via systemctl): Job for odoo.service failed because a configured resource limit was exceeded. See “systemctl status odoo.service” and “journalctl -xe” for details. [FAILED]

[root@meds stephen_otieno]# journalctl -xe

Jul 08 09:14:01 meds odoo[2855]: odoo.cli.main() Jul 08 09:14:01 meds odoo[2855]: File “/usr/lib/python2.7/site-packages/odoo-10.0.post20190619-py2.7.egg/odoo/cli/command.py”, line 64, in main

the full log is here pastebin

Can you check the resources in the system?

  1. Do you have enough space & memory?

df -h

  1. Whats your machine’s configuration? and how many components have you installed (e.g. EMR, LAB, ERP etc etc)

  2. Can you stop any other existing service, start odoo and see

service bahmni-lab stop
service bahmni-reports stop
service dcm4chee stop
service odoo start

My server in 15GB RAM, have tried to stop other service and start odoo but still get the same error.

How can I uninstall and reinstall odoo alone

(use the --only option of bahmni installer)

> service odoo stop
> yum remove bahmni-erp
> rm -rf /opt/bahmni-erp

backup the odoo database, and drop the db (not necessary or desirable all the time, but lets do this to ensure that everything is clean)

> psql -Upostgres
> drop database odoo

now, install ERP again

bahmni -i local --only bahmni-erp install

A new version 0.92-118, is available now from our s3 repo. You can download from here

Fixes:

  1. BAH-848: Bahmni EMR rpm installation does not create bahmnicore properties file
  2. BAH-844 Integration between MRS-ERP fails if Lab Component is not installed
  3. BAH-841 Discount Amount is not calculated in Journal Entry while validate Invoice - fix for the Net amount calc
  4. BAH-847 - “Default” implementation installation shows an existing customer and an order associated

The same build is available now at product-qa08 env

Please keep up the good effort on testing. Much appreciated.

1 Like

I have followed the steps and I Am getting this error

Traceback (most recent call last): File “/usr/bin/bahmni”, line 11, in load_entry_point(‘bahmni==0.1’, ‘console_scripts’, ‘bahmni’)() File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/core.py”, line 764, in call return self.main(*args, **kwargs) File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/core.py”, line 717, in main rv = self.invoke(ctx) File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/core.py”, line 1137, in invoke return _process_result(sub_ctx.command.invoke(sub_ctx)) File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/core.py”, line 956, in invoke return ctx.invoke(self.callback, **ctx.params) File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/core.py”, line 555, in invoke return callback(*args, **kwargs) File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/decorators.py”, line 17, in new_func return f(get_current_context(), *args, **kwargs) File “build/bdist.linux-x86_64/egg/bahmni.py”, line 79, in install File “/usr/lib64/python2.7/subprocess.py”, line 542, in check_call raise CalledProcessError(retcode, cmd) subprocess.CalledProcessError: Command ‘ansible-playbook -i /etc/bahmni-installer/local all.yml -vv --extra-vars ‘@/etc/bahmni-installer/rpm_versions.yml’ --extra-vars ‘@/etc/bahmni-backrest.conf’ --extra-vars ‘@/etc/bahmni-installer/setup.yml’ -t bahmni-erp’ returned non-zero exit status 4

We have not come across this error. Googling results in this

What version of CentOS are you using?

Centos 7.6, could this because of python version? Eveything is installed by bahmni

Possibly. or some dependent library issue. Have you tried with the link above, there is a reply about updating wsgidav

Dear All, a new build is available for download: http://repo.mybahmni.org.s3.amazonaws.com/rpm/bahmni/bahmni-installer-0.92-120.noarch.rpm

Has fixes for

  • BAH-852: Upon installation (default) odoo screens appear broken
  • BAH-850: District is not filled for customer address fields when synced from OpenMRS
  • BAH-851: Lab Results do not appear on Bahmni Clinical (e.g. Dashboards) against the order

Latest Build is also available at product-qa04 env

thanks will checkout

Dear All, We are scheduling some sessions next week. First one: Session: Integration with Odoo

Please let us know your availability here

Dear All, the poll shows only 4 attendees, and we know there are many who are trying out with Odoo in 0.92. We are thinking of doing this tomorrow, (as of now, by the poll it should be today), so that others may have time to respond.

@ramashish @sushmit @arjun @sushilp @laxman @dipakthapa @sanjayap @sandeepe @stephencoduor @anandpatel @ajeenckya @mksrom

We will have the session at 4 pm IST, Tuesday (i.e 10:30 am UTC) We will use zoom https://thoughtworks.zoom.us/j/531292434

@angshuonline Please record the session.

@angshuonline may I know! was it recorded

@stephencoduor we couldn’t record it. We will be creating a video though in the next few days.