Very Difficult Installation

I am working in IT for 20 years now but I never come upon such a difficult installation procedure, I have spent one week trying to install the reference application and it still does not work, the problem is that the installation procedure is not correct, it should specify the system requirements for a correct installation, for example it stated that I should download the latest version of MYSQL so I installed version 8 but the database could not be created because the installation package apparently uses old commands to create the tables and I had to learn that the hard way by removing MYSQL 8 and installing 5.7 and then the tables got created. another problem is that I am installing on windows 10 - 64 bits. and apparently the appdata file is in a different location than what is expected so that caused problems again and even after identifying the appdata location which is under the user account not system32 as explained in some threads still the ui will not load and I tried everything. usually software will have an installation package that will verify the location of all the files it needs and whether it got installed properly or not but it does not happen here. so please someone just put the system requirements, for example windows 7 32 bits, my sql 5.7 apache 8 or so forth so I know what to install exactly and it would be easier for troubleshoot. also after I checked the log files of apache apparently It could not locate some files, I don’t know why, maybe it will not get installed in the same location for this version of windows. finally I decided to install a virtual box and try all the different scenarios there until I find something that works. installing software should be easy.

You are welcome to this community @abulfatih. So sorry about the difficult installation procedure, we are doing something to improve on the documentation of the procedures so that such installation become smooth in the near future.

cc @jwnasambu , @tendomart , @dkayiwa , @c.antwi , @jennifer , @burke , @herbert24

1 Like

sorry @abulfatih about that and welcome to the community, kindly check out this to

@abulfatih Have you managed to install? We have taken your feedback and will ensure that we improve on the documentation. You may also feel free to update the documentation based on what you have seen.

Thanks for your support

1 Like

@abulfatih Agreed that things may be a bit tricky a first. You might want to look into OpenMRS SDK to make things easier. It installs everything for you(including the mysql database should that be a barrier)

Just as an update after doing everything possible! edited the web.xml file to increase the file size allowed to load, ensured to isntall 64 bit version of tomcat, java and mysql , corrected the text copied from the tutorial that states that user name = admin to user username = admin (i really don’t know which one is correct as different sites mention different syntax and that is why someone should paste which version of what should work wit what! ) it still didn’t work! i coped the omod files to the modules directory and the owa files to the owa directory which both where found if searching with %appdata%

the problem that i still get the message “If you are seeing this page, it means that the OpenMRS Platform is running successfully, but no user interface module is installed” the strange thing that I was able to make it work in a different computer but there i faced another problem is that allot of modules did not start because the emrapi module could not be started and allot of the other modules depend on it!! how can the same installation of two different pcs have two different problems!

I will try different scenarios using oracle vm virtual box but this will take forever!! should I use old versions of everything? maybe then the deployment will work!

i am trying to install the reference application 2.8.1 for production use and have downloaded the platform 2.2.0 war file and the reference application 2.8.1 addons.

I need to make this work so I can start configuring opemrs. the standalone edition was very easy to install but that one is for one computer only as i presume and I want to install it for a clinic with 2 PCs, one PC will be used by the nurse/receptionist and it will be the server and the other will be the PC used by the doctor.

For the server with no user interface modules installed message, can you share its tomcat log via

I have a suspicion that OpenMRS will not work with windows 10 . I will try doing everything again on windows 7. maybe the security settings will not allow certain things. also I noticed from some log files that it is storing some files in the folder application data but in windows 10 it is called app data! I think openmrs is trying to read and write from folders and it cannot find them so it will not load the modules. correctly.

@abulfatih Yea installation can be tricky especially if you’re trying to do everything manually. I would suggest what @reubenv said - try the OpenMRS SDK and select the ‘Distribution’ option. Make sure you’re on JDK 8 and not JDK 11. Here’s the link to the OpenMRS SDK guide :

1 Like

can you please share the download link for the sdk?

Please see the Installation Guide here

@abulfatih can you edit your paste and replace it with a link that has the contents?

i have noticed that by using %appdata% it takes you to a location app data but actually the modules and owa folders are in a folder called application data in the system32 folder instead of under the user folder. I don’t know but where openmrs is trying to read from. i am trying now to do a full clean installation on windows 7 32 bit instead of windows 10, i tried both windows 10 32 bit and 64 bit and it didnt work

oh god even in win 7 it didn’t work! the error is different now! here is the error i get

and this is the error log for the windows 10 problem

Thank you in advance for all the help

The errors you are getting have nothing to do with the version of operating system that you have. Which OpenMRS platform version and emrapi module version are you running?

I followed this link

and downloaded under Reference Application 2.8.1 the Platform 2.2.0 and copied all the files from the Reference Application 2.8.1 addons archive, so the emrapi version included there is 1.24.4

can i just use the standalone version? it is straight forward to run with no problems, I need it for 2 persons only on two different PCs, can one person access the application hosted by the other person by using his ip address instead of localhost?? I wanted to use the advanced installation because it can be started automatically as a service and both the doctor and the nurse of the clinic where I want to install have some difficulty with computers and software in general so I wanted it to be as easy as possible. in fact all they need is to maintain the records of the patients, they don’t want any extra modules, they are using an excel sheet now to keep the name and the phone numbers of the patients only and all the records are in hard copy which makes it very difficult for them to have any kind of statistics about persons sharing a common disease for example.

As for the modules, can you use these ones?

I used these modules but they won’t load, i still get the message “If you are seeing this page, it means that the OpenMRS Platform is running successfully, but no user interface module is installed”

I noticed that when you deploy openmrs.war file it says that the proprieties file will be in C:\WINDOWS\system32\config\systemprofile\Application Data\OpenMRS\

but I found it also in C:\Users\Hamed\AppData\Roaming\OpenMRS

so there are two copies of that file, I don’t even know if this is relevant

ok now i stopped apache and deleted all the log files and then started apache again and and opened openmrs.

here is the new log file, the user interface still does not load

i am suspecting that each module will not load because it depends on a certain version of another module and because the bundled module is not that version so it will not start.

this is the log of the file openmrs.log found in systemprofile\application data\openmrs