Tired of feeling so "null"? Become a /dev/1!


(Burke Mamlin) #21

Yikes, you’re right. It appears the Smart Developer badges were reverted for some reason. I suspect a script connected to the badge (i.e., it’s not fully manual). I’ll investigate and report back. Don’t worry, you’ll get your badges back. :slight_smile:


(Burke Mamlin) #22

As I suspected, Discourse was hiding some SQL behind that badge. Badges were being driven by a hidden group. I’ve removed the SQL (making it a manual badge as I assumed it was), deleted the group, and then went back and re-assigned all the badges the bot had given out yesterday. The /dev/1 badge is automatic & runs daily, so it could take a day for that to show up for folks. Otherwise, we should be good now.

Thanks for the heads up, @piyush9620!


(Robby O'Connor) #23

Why not just add them to the group @burke?


(Robby O'Connor) #24

Also @burke https://github.com/bmamlin/openmrs-contrib-quizgrader/pull/1/files


(Burke Mamlin) #25

There’s no need to have a group for people who have passed the quiz.

Thanks. Not really important for this app, but good to know about the alpine-node images. I tried out the alpine-node image and it failed to run. :confused:


(Robby O'Connor) #26

I fixed it – try again?


(Collin Grimm) #27

I’m facing the exact same issue right now :slight_smile: @burke said it might be a script, but I got my badge a few days ago. And today when I checked it was not found. Even the /dev/null badge I earned a long time ago has disappeared :weary:


(Burke Mamlin) #28

Ack! If it’s not one thing, it’s another. In this case, I’m guessing the SQL script for assigning /dev/1 (maybe all of /dev/1+) are looking at the Smart Developer group instead of the badge assignment. I’ll look into it and report back.

Update: Indeed, this turned out to be a typo in the SQL query for /dev/1 badge assignment. I’ve fixed it. Things should be fixed when the badge assignment scripts run tonight (i.e., in <24 hours). @grimm, thanks for the heads up. Please report back if your badges aren’t fixed by tomorrow.


(Collin Grimm) #29

OK @burke will do :thumbsup:. I’m still waiting though. :smiley:


(Collin Grimm) #30

@burke, I got the badges now :slight_smile: Thanks


(Burke Mamlin) #31

Yay! Hopefully that’s the last bug and people can get through /dev/null to /dev/1 automagically going forward. :sunglasses:


(Yusuf Karim) #32

@burke I’ve taken the quiz and have still not received any email or update regarding the result of my quiz. Is the script working properly?


(Burke Mamlin) #33

Now it’s an issue with the service that transfers entries to the google spreadsheet. @ykarim250, your responses got transferred, but some key fields up front did not for some reason, including your OpenMRS ID, issue URL, and PR URL, which prevented the bot from being able to grade the entry. I populated those fields manually and triggered the bot, so you should have gotten notified.

Now I have to figure out why the front-end fields aren’t getting transferred. Still :bug: so :bug: many :bug: bugs! :bug:


(Yusuf Karim) #34

Thank you @burke hope you’re able to fix those bugs soon good luck


(Burke Mamlin) #35

Okay. I sorted out the problem. It turns out Zapier’s Survey Monkey → Google Spreadsheet zap is very sensitive to any change in the survey. I had tweaked labels on a few questions and those were the ones that weren’t getting transferred (including OpenMRS ID!). Now that’s sorted.

Hopefully, the last “problem” will come in a few days when our free trial period of Zapier ends. I’m hoping the transfer zap will still be available (major bummer if it isn’t)… but expect we’ll lose multistep zaps, meaning I won’t be able to notify the grader when a new entry arrives and have to configure the grader to run every 10 minutes or something like that.

In any case, I’m crossing my fingers and hoping the last of the bugs have been squashed.


(Reuben Varghese) #36

@burke It’s been over a day since I’ve taken the quiz and I too haven’t received the badge or any email regarding that.Maybe the script malfunctioned again?


(Burke Mamlin) #37

Thanks for the heads up. I’ll take a look and report back.


(Burke Mamlin) #38

I went to Zapier and manually ran the zap that transfers responses to a Google spreadsheet and tickles the grader. It looks like it worked for you.

That zap is supposed to run every 15 minutes. Not sure why it wasn’t running. Our Zapier account did transition from a free trial period of basic service to their free service plan, but I didn’t see anything saying that background zaps wouldn’t run on the free plan. It’d be hard to justify $20/month for this one zap. :neutral_face:


(Robby O'Connor) #39

Could use something else:


(Reuben Varghese) #40

@ burke Thank you :slightly_smiling_face:. Yes I do agree that there’s no value in 20$/month for just this. Maybe we should think of better way of hosting the quiz? Probably we could create our own webpage to handle the quiz data? And I just tried and /Dev/1 wasn’t available in my profile preferences for use as a title. Could you check this too please?