There was an error while updating database to the latest

Application Name: Reference Application Version Number: 2.4.0 SNAP-SHOT

Question: I am getting a DatabaseUpdateException when intalling openmrs I am using MySQL 5.6.10 , please see attached error message

Error while trying to update to the latest database version org.openmrs.util.DatabaseUpdateException: There was an error while updating the database to the latest. file: org\openmrs\liquibase\updates\liquibase-update-to-latest-2.0.x.xml. Error: org\openmrs\liquibase\updates\liquibase-update-to-latest-2.0.x.xml does not exist at org.openmrs.util.DatabaseUpdater.executeChangelog( ~[openmrs-api-2.4.0-SNAPSHOT.jar:?] at org.openmrs.web.filter.initialization.InitializationFilter$InitializationCompletion$ [openmrs-web-2.4.0-SNAPSHOT.jar:?] at [?:1.8.0_162] Caused by: liquibase.exception.ChangeLogParseException: org\openmrs\liquibase\updates\liquibase-update-to-latest-2.0.x.xml does not exist at liquibase.parser.core.xml.XMLChangeLogSAXParser.parseToNode( ~[liquibase-core-3.10.2.jar:?] at liquibase.parser.core.xml.AbstractChangeLogParser.parse( ~[liquibase-core-3.10.2.jar:?] at org.openmrs.util.DatabaseUpdater.executeChangelog( ~[openmrs-api-2.4.0-SNAPSHOT.jar:?] at org.openmrs.util.DatabaseUpdater.executeChangelog( ~[openmrs-api-2.4.0-SNAPSHOT.jar:?] … 2 more

How are you running OpenMRS? Using the SDK?

Yes @dkayiwa am running it using the SDK how ever I was able to sort out the issue. I had an existing “openmrs” database so I changed the database name during installation and it worked.

Thanks @sidwelldev for sharing! @gcliff could you try this too?

1 Like

thanks @sidwelldev

Are you running on windows environment or mac or linux?

I am running on windows.

1 Like

hello @sidwelldev could your share your sdk logs when setting up your reff app 2.11.0 SNAP-SHOT

hello @sidwelldev @dkayiwa i have tried to change the db name but am running into the same errors reported in this thread … These are my sdk logs

1 Like

@gcliff do you mind doing it again with a database named ‘kayiwa’?

1 Like

sure ,no problem

@dkayiwa I have tried it again with kayiwa as the db name but still arrived at the same errors in the installation wizard

hi @gcliff I did another installation on my mac today and it worked like a charm. i was just following the same steps I did on Windows. Please find attached log openmrs_sdk_logs.txt (127.9 KB)

1 Like

@gcliff I am facing same problem today.Did you find any solution for this?

Dear, @mukesh I from facing the same issue, I found out when the liquidbase creates migration tables before the auto generation of all tables that’s when the challenge comes in. What you can do delete all the tables in the openmrs database then re-run the mvn jetty:run(that’s if you’re using jetty server)

@abertnamanya I am using following command and this is working like charm,.

mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:4.1.1:setup -DserverId=test_instance


This worked for me too. Thanks Mukesh