Updating openmrs database during installation

Tags: #<Tag:0x00007fe6dbc6f218>

Successfully? And then after two hours it fails?

No please i have not run it successfully, rather after running it i encountered similar error , in other words i couldn’t access it via UI, the same screenshot above is the same am getting also

Then am confused by your reply to the above.

I Haven’t run it successfully so fur

@gcliff i remember as if you successfully set this up a couple of weeks ago. Correct?

yes @dkayiwa

i have just run the platform server that i set up a few weeks back and it works fine

dont know why the currently set up platform servers ain’t responding appropriately

1 Like

Great @gcliff, can you try again with latest platform atleast with latest changes , just want to be sure whether we get either same or different logs

@sharif when i try with the latest platform and its changes i get the first errors above

1 Like

Try to run a specific version of the sdk with: mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.13.6:setup

And: mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.13.6:run

2 Likes

@dkayiwa i have run the first command and its shows 2.3.2-SNAPSHOT as the latest platform version snapshot

Choose: 7) Other...

hello @dkayiwa i have run in to this error which is prohibiting the setup

i have droped the database and deleted the runtime properties file but still encountering the same error

Confirm that your MySQL instance is running on that port.

i have fixed it,was punching in an incorrect password .

Thanks

i have set up the server with this command

on running this command i get this error

And the log?

@dkayiwa

https://pastebin.com/Z4ffNyTH

Thanks

Can you try again after doing a full mvn clean install on openmrs-core, having the latest upstream changes?

@dkayiwa I have done the fresh build with the latest changes from upstream , deployed the new war file in the platform server but on running the server,am still facing the same error

@dkayiwa kindly requesting for your help

Thanks