Strange behavior in openmrs-sdk with adminui

So I just set up an openmrs-sdk server instance to watch a local clone of the openmrs-adminui repo and I ran into the following error (server would not start): [ERROR] Failed to execute goal com.mycila:license-maven-plugin:2.6:check (default) on project adminui-api: Resource license-header.txt not found in file system, classpath or URL: no protocol: license-header.txt -> [Help 1]

This error occurs even though mvn clean install works fine in openmrs-adminui.

The workaround I found was to copy openmrs-adminui/license-header.txt to openmrs-adminui/api/license-header.txt and openmrs-adminui/omod/license-header.txt

I’m not sure this fully qualifies as a bug, but I wanted to mention it on the talk pages in case anyone else has the same problem. It seems like this issue (or one similar to it) came up at least once before: How do I setup OpenMRS core to compile in eclipse?

Also, if anyone has a less hack-y solution definitely let me know.

@adamg @tmarzeion @raff i hope you saw this. :slight_smile:

Does updating license-maven-plugin at to version 3.0 fix the issue?

I’m still getting the same error after changing to version 3.0, unfortunately.

I’m not sure why the issue occurs for SDK… It seems like a bug in the license plugin. The other workaround I found was inlining the license in pom.xml, which I guess is better than duplicating the file. Committed in

That’s working for me too. Thanks @raff!

Big fan of the sdk, by the way. Can’t imagine working on openmrs without it.

Worked for me also with an initial “mvn clean install” with a manual setup. Thanks!