Standalone Edition un able to open

Open MRS standalone Edition version 2.12:

I downloaded the Open MRS software but it failed to open up, so am requesting help on that.

are you using a Mac??

No sir, am using windows 10

Can you provide the following details?

  • What Java version is installed on your PC?
  • How did you try to run the application?
  • Are you seeing any errors?

Can you also share the log files in the following locations?

  • referenceapplication-standalone-2.12.2/appdata/openmrs.log
  • referenceapplication-standalone-2.12.2/tomcat/logs/

java version “21.0.2” 2024-01-16 LTS.

Well, I extracted the application but when i tried to open the jar file, it does nothing.

But i have tried to use the open MRS distribution but am stack on the server id

Make sure u have maven in you PC it may be a case but bring out the error log so as people can see the specific problem

Could you give it a try with Java 8? I don’t think Standalone supports Java 21. You can download Java 8 from here: Java Archive Downloads - Java SE 8

Users don’t need to have Maven installed to run the standalone.

ok let me try it out

ok, I think it was the problem may be

i have installed java 8 but its the same story

Could you please open your command line in the folder containing OpenMRS and run the following commands?

java -version

java -jar openmrs-standalone.jar

Share the output with us after running these commands.

these are the results

Can you run the dir command to make sure that you are in the correct folder?

May be I did not get your question clearly but when I run the dir command, this is what I got

You need to open the command line from within the OpenMRS standalone directory. Follow these steps:

  1. Open the OpenMRS reference application standalone folder using your file manager.

  2. Hold the Shift key and right-click in an empty area of the folder

  1. Select Open in Terminal from the context menu.

  2. In the terminal, run the following command:

java -jar openmrs-standalone.jar

This should start the OpenMRS application, If there are any problems please share the output from the terminal by copying and pasting it to here:

I have tried it but it failed it this is the result

C:\Users\Admin>java -jar openmrs-standalone.jar Error: Unable to access jarfile openmrs-standalone.jar

Did you follow my instructions? It looks like you are not trying to run the command in the openmrs standalone folder.

Sir am doing my best but these are the results

PS D:@Software\openmrs-standalone xtrct-2.5.0\openmrs-standalone-2.5.0> java -jar openmrs-standalone.jar Attempting to load properties file in current directory: Using runtime properties file: Exit:1 Unrecognized VM option ‘PermSize=256m’ Error: Could not create the Java Virtual Machine. Error: A fatal exception has occurred. Program will exit. [MysqldResource] Mysqld not running. No file: D:@Software\openmrs-standalone xtrct-2.5.0\openmrs-standalone-2.5.0\database\data\ PS D:@Software\openmrs-standalone xtrct-2.5.0\openmrs-standalone-2.5.0>