Problem Setting up Drug data using CSV import

Application Name: Reference Application Version Number: 2.6.0

Question: My team and I are trying to use the /drug endpoint to get data and manipulate it for use in a DrugOrderComponent that we are working on. Problem is the endpoint returns empty responses meaning these is no drug data in our current dataset. I have tried to manually add drug data via the concept dictionary and that works, but it will take time and is not scalable. I have Drug data in .csv format. How can I upload this/ add this data to the standalone application?

Are you aware of this?

Yes @dkayiwa I checked it out and tried importing but the version 2.6.0 is currently not supported, so the import fails

What error did you get?

You could try leveraging the ‘drugs’ domain that is processed by our Initializer module.

  • This is an example for the drugs CSV file.
  • And here the ad-hoc concept drugs CSV that goes with it.

This set of instructions do not work as the named repository does not exit. So I cloned the dev branch and this is the error I get when trying to install with maven:

Until this is done, you may have to skip tests:

mvn clean install -Dmaven.test.skip=true

Disclaimer: All this is still under development.

1 Like

Thanks @mksd the error still persists. I think it can work once all dependancies and included.

Weird, you should clone and build Ext I18N beforehand in that case. Just for the sake of being able to build Initializer.

@upendo, one option is to install the CIEL concept dictionary. (Instructions are here.) This has both a lot of concepts, and also some drugs (I think it’s the WHO Essential medication list, or something).

I will try this and give inform you how it goes.

Thank you. The install was successful and the omod folder was generated. I will embark on an install tomorrow and tell you how this goes. Thanks again.

1 Like

@mksd, How do you install the built omod to the Openmrs instance?

@upendo, in the meantime Ext I18N was moved into an OpenMRS-owned repo, meaning that you can just rely on its snapshots safely from now on as they will be available on Nexus:

You can use the legacy admin UI interface at this URI: /openmrs/admin/modules/module.list Or you can just copy the OMOD file in the modules directory of your OpenMRS instance and then restart OpenMRS.

I have increased max_allowed_packet to 128M as defined here But this is the error I get.

Did you get a chance to look at this?

I found out that adding this to my file increased the packet size. But I now get a new error message: I am importing the from dropbox, is this the right way to do it?

I am trying to update concept data but that is the error I am getting.