Problem accessing localhost:8080/openmrs/admin


I get the following error while connecting to localhost:8080/openmrs/admin although the localhost:8080/openmrs works successfully. The error is as follows: Establishing SSL connection without server’s identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn’t set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to ‘false’. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification I tried doing useSSL=false in my server’s properties but that doesn’t seem to work. Any help regarding this would be appreciated. Thanks in advance!

hi, @varung31 I have found the solution for this. visit this link for step by step process -

@varung31 have you been able to overcome the blocker following the link provided by @devanshk09? Let us know your progress about this issue.

Sadly no. I am able to run localhost:8080/openmrs but when I go to localhost:8080/openmrs/admin, I get 404 error.

I am trying to load the basic hello world module as in getting started as a developer.

So sorry about that @varung31, However, since you want to load your module please just go to localhost:8080/openmrs, select a location and log in. After logging in click the icon for System admin , click Advanced Administration, click Manage modules under the modules section then you will be directed to the modules where you will find upload module in the top left side of the page. Let us know in case of any more help you need.

What location are you talking about ? I don’t see any location in the screenshot of openmrs I shared with you above.

When you are on the login page, normally there are locations for example Registration desk, Outpatient clinic etc. So you have to select one of them for you to be able to log in.

Oh okay, but I am not redirected to the login page after installation. Any help regarding that ?

Ok I get you . Could you share your logs. Or the steps you have followed to get to this point?

So, I cloned the basicExample directory and then ran mvn openmrs-sdk:setup to setup a new server.

I changed the server properties to include useSSL=false. After that, from within the basicExample directory, I ran mvn clean install openmrs-sdk:run. Now, I go to localhost:8080/openmrs and complete the installation setup there. I now see openmrs successfully running

Your output shows that you have the platform running but no user interface module and suggests that you read about the user interface modules. Could you take time to read about the user interface modules to get a broad view of what is happening?

Sure.I’ll get back to you.

Ok @varung31 just go ahead and read then we shall be waiting to get your feedback. cheers :slight_smile:

As you read on, Do you remember the type of server you chose to build? (either Platform or distribution). That’s where the issue begins from.

Yeah I chose Platform. So, I am trying to install the legacy UI thing. Am I doing the right thing ? Because it still shows the same thing.

@varung31 Try and see what it brings or else you may want to build the distribution.

I think I don’t clearly understand the difference between platform and distribution ? Could you please share something regarding that ?

Platform comes without UI modules whereas distribution comes with UI modules. In your process of building the server you can just choose any of the two depending on what you need to do.

Hi! I can now access the admin page and see my basic example module there. But I have a few queries regarding that:

As you can see, there are a few errors on top. Is there a way to correct them ? Also, when I click on basic example I get 404 error. Is that how it has to be ?

Read the message in those errors above you will know why they are there. Have you uploaded the module?