Platform 2.1.2 Release Tentative Date

The sourceforge folder is supposed to be created by you. Take a second look at the release process instructions. Hopefully you have also started creating the release notes wiki page.

1 Like

ok. yes i have started.

Hello Devs, are there database changes between Plaform 2.1.2 version and 2.0.6? and if yes which ones are they?

@irenyak1 doesn’t the platform release process page state how you should find that out?

When i follow the wiki page still I am not able to edit that page, earlier on i created a help desk case for my sourceforge account to be given rights for Openmrs account. I have created another case. I am thinking i dont have rights that’s why am not able to edit that page.

Which page aren’t you able to edit?

https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_Platform_2.0.6/

This one https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_Platform_2.0.6/

You should not edit that because the version you are releasing is not 2.0.6

Then i need guidance because I am not sure how to go about this step, I have tried to figure it out though am still not getting it right.

Are you logged in on sourceforge? If yes, do you see the “Add Folder” button on this page? https://sourceforge.net/projects/openmrs/files/releases/

This is how my page is displayed after i have logged in.

Looks like your account does not have permission to create the folder. Just created it for you https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_Platform_2.1.2

Thanks. I was wondering why i could not easily trace that ‘Add folder’! though I created a case on help desk to avail me the previleges. :slight_smile:

Please I need the permission to create folder/ add files because without that I can not populate that folder you created.

@irenyak1 my account does not have permission to give you those rights. Since we are releasing today, you will just point me to the files you need to upload there and i do it for you.

1 Like

From the Release process guide, it indicates that those folders ( Openmrs-standalone-2.1.2.zip, Readme.txt and Openmrs.war) are automatically created in sourceforge when i run the CI build. How I’m I supposed to go about it now that they were not created?

The issue was that @irenyak1 did not release the platform from CI, just the core. Files should be pushed to sourceforge once release of https://ci.openmrs.org/browse/OP-OP21-2 completes.

BTW it’s stated in release instructions… step 11.

1 Like

It’s just unfortunate that maybe I accidentally skipped it though it was well marked on my checklist. Really sorry about that.

No worries :slight_smile: There’s still too many steps in the process that can be easily skipped. We just need to continue to make the release easier.

1 Like