Patient Display error on openmrs

Where do I get the full server side java log in ubuntu?

Here is the full tomcat log.

What is your database’s character set and collation?

Database character set is “utf8” and collation “utf8_general_ci”.

What is the value for connection.url in your runtime properties file?


Do you still have a backup of your database before you upgraded from 2.0.6?

Yes I do have a backup.

Try restore the database and check if the problem persists.

Restore 2.0.6 backup on 2.3.5 openmrs?

Restore the database and openmrs war file to 2.0.6

If I restore it to openmrs 2.0.6 I don’t have this problem because I have tried it before when I first observed it. I even try to upgrade it to 2.3.2 first. Then problem starts after I upgrade.

Maybe I should restore openmrs 2.0.6 then upgrade it to 2.3.5 and post the log files here.

First go back to 2.0.6 and confirm that all is well with the patient dashboard. Then replace the war file with the new version and check again the patient dashboard.

I restore my database on openmrs 2.0.6 and I could observe the patients fine. I have upgraded to openmrs 2.3.5 and the problem is still there. The patient dashboard is not displayed at all for some patients. Here is the log file from when i started to upgrade from 2.0.6 to 2.3.5 Blank patient dashboard -

Does OpenMRS 2.2.x work well?

I have try openmrs 2.4.x, 2.5.x and the problem still exists. I have not try openmrs 2.2.x. Maybe I should try on 2.2.x and see what happens even though eventually I will have to move to 2.4.x or 2.5.x.

Openmrs 2.2.1 seems to be working fine so far.

How about 2.3.0?

I have tried 2.3.2 and 2.3.5 it didn’t work. I will try 2.3.0.