Ozone HIS FOSS error in login page load after successful install

Hi all,

I just tried running ozone-docker FOSS and i am getting errors. I think i should get a login screen but i am seeing the dashboard instead. I followed the instructions in README to the letter. Any pointers would be much appreciated

@banji I know that this isn’t addressing directly your question, but from Monday we are starting a sprint to accelerate the release of Ozone 1.0.0 alpha. This should hopefully solve a lot of problems in the next two weeks.

Thanks for your patience!

Cc @grace

1 Like

Thanks for the update I am greatful

Hello, any update on this pls? :wink:

Hello @zotis we have been busy on this. Updates coming out soon.

1 Like

Hi @achachiez , thank you very much :slight_smile:

@zotis for now the best way is to follow the Ozone 1.0.0 sprint updates on :point_right: Slack, but you’re highlighting the the fact that I should have crossed posted on Talk too :disappointed:

2 Likes

Hi, I am still having an issue even after pulling the latest changes.

The setup screen (http://localhost/openmrs/index.htm?lang=) shows this: Screen Shot 2022-11-25 at 5.31.26 PM

And visiting the spa/dashboard page afterwards shows a blank screen with the banner “Oops! An unexpected error occurred.”

@achachiez any help for @zotis here?

@zotis I am assuming you are using the manual setup instructions? At this point we should actually be running on OpenMRS Core 2.5.8 we track the reference app

I can see you are are on 2.4.6 I don’t think that is the main issue here but I need to understand how you start the project

HI @achachiez - thanks for looking into this. I follow the steps outlined here: GitHub - ozone-his/ozone-docker: A Docker Compose setup for running Ozone HIS

I just ‘git pull’ the latest changes on the main branch. I see it has updates from a couple of hours ago. I removed the previous container by running ‘destroy-demo’ script, then re-ran ‘start-demo’. I still see 2.4.6 on top.

When I visit, localhost/openmrs/spa page, I see a blank page with an error message below:

I’m super glad to see progress is being made on this! I am following closely Great work all! We are in your wake …

@zotis something’s definitely off with your setup as the version of Core that Ref App 3.x provides is currently 2.5.8, see here. And you’re showing a screenshot that refers to Core 2.4.6.

Could you start the quick start process from scratch again, and report back?

1 Like

@mksd - I deleted the repo and restarted from scratch. It worked! Thank you. My understanding of the issue:

  • It seems to be related to the /ozone (build?) directory which gets generated after running start-demo script.
  • The directory doesn’t seem to be regenerated even after destroy-demo and start-demo. It needs to be deleted manually.

Glad to know you got it working. Quick one please, which version of docker and docker compose you use?

@zotis were you finally able to logging? It takes a little bit of time for OpenMRS to be ready the first time.