Order Entry UI 404

Hi all,

I’m a newbie in OpenMRS and trying to develop a telemedicine platform based on restful APIs of openMRS. I deployed the 2.9.0 reference application distribution with SDK and it works perfectly. Since we hope that Orders will be one of the most important and attractive functions of our product, I then installed order entry UI 1.0 through module management section in application. However, I got a HTTP Status 404 - for http://localhost:8080/openmrs/owa/openmrs-owa-orderentry/index.html?patient=87672224-c3c2-40ca-9a45-2863bfb99f21 when I go into PRESCRIBED MEDICATION section in a patient page. Can someone please tell me if I missed any steps or did anything wrong? Thanks in advance.

Oh, to complete the background, I have configured global properties as required in guide and it didn’t help.

Is this the version of the app that you are testing? https://addons.openmrs.org/show/org.openmrs.owa.orderentryui

Can you also attach some screenshots for what you are seeing?

Thanks for helping Kayiwa.

This is the version I’m using. Though I didn’t get the owa from there manually. I installed the add-on in module management UI.

And here are the screenshots:

Upgrade your orderentryui module to the one attached on this ticket and test again: https://issues.openmrs.org/browse/OEUI-40

I released it here: https://addons.openmrs.org/show/org.openmrs.module.orderentryui

I removed the old order entry UI module, put the new omod in module folder and restarted the server. Though I still got the same error.

Are you able to paste the server side log at pastebin.com?

Here is the recent log. No error was logged. And highlighted part is the log generated when I click on that PRESCRIBED MEDICATION button and go into 404 error page. https://pastebin.com/7BeNbPet

Can you paste the full log at pastebin.com?

Here is the full log since I just removed the old log file and restart the server. The old log exceeds the size limit. https://pastebin.com/TbuGALzt

Am also facing exactly same issue.

Thanks Prapa

1 Like

Which version of the module are you using?

Latest docker image : openmrs/openmrs-reference-application-distro:demo

Thanks Prapa

I mean version of the orderentryui module as shown in your manage modules page.

I am also having the same issue. I tried several versions but still got error 404. Openmrs - Version: 2.2.0 Build ab94ff order entry ui versions i tried : 1.0 / 1.1.0 / 1.2.0-SNAPSHOT

Any update on this.

@dkayiwa is anyone working orderentry ui module?

Same issue here! Did u find any solutions?