file not being created


I’m trying to install OpenMRS 1.7 (in order to upgrade it to something greater). I get the error in the attached screenshot. It leads to the databases not being created.

I’m wondering if installing OpenMRS 1.7 with tomcat requires any special actions. The current lead I’m following is the possibility that the mysql installation did not work properly. (Mysql works through the GUI, but not the terminal.) I also don’t see the path to the mysql bin listed in the $PATH environmental variable. Instead the command below gives me the following output.

hg:~ Harold$ echo $PATH​ ??

(Yes, those question marks were the actual and only output of the command. )

I’m working on a Mac OS X 10.11.3 (El Capitan).

Do you have any reason for not upgrading directly to 1.11.5?

Hi @dkayiwa! basically Harold is part of the Indy based IHIE team who use OpenMRS 1.7 for their NCD work. He needs to set up his system with 1.7 to do some initial testing, after which i’m going to help them to upgrade the IHIE implementation to OpenMRS 1.8.3 or greater. But to move forward with the upgrade to something more recent, we need to make sure that the current system works properly. Given that I’ve never worked with OpenMRS 1.7, I wanted to see if anyone had any advice on how it is setup for testing :frowning:

You will need to paste the full log somewhere and give us the link to it.

Where can I get the log? I’ll send you a link to the log soon after.

Harold, What was the outcome of your attempt to get NCD running? Did you succeed?

I also have this problem

i’m trying to implement Relationship-Based Access Control for OpenMRS( below is my environment OS: Fedora24 Java version : 1.6.0_45 Maven version : 3.0.3 mysql version : 5.7.17

I run [ mvn clean install -DskipTests=true ] on core directory if build successfully, run [ mvn jetty:run ] on webapp directory.

Also tried deleting ~/.Openmrs directory and re-building but error still says can’t find

Can you paste the full error log at


here it is

Did you get this from a log file? If yes, what is the file name?

Can someone help me please? I just spent a week trying to solve this problem but without success

Your error is not related to what is being discussed in this thread. Can you start a new thread?

@hgil Were you able to create the file?

Hey Guys,

Am facing the above error as well @asaidi if you happened to resolve please share the solution. Also I will appreciate if anyone can assist me with this. Thanks

Openmrs still throws this exception while deploying to tomcat.

Error! A runtime properties file is needed for OpenMRS to start up consistently. OpenMRS is unable to create this file : /var/lib/OpenMRS/ Because of this error : No such file or directory

You must correct this before continuing.



I was not able to get the file to work on my machine. Suranga was able to get it to work on his easily so it seemed to be related to my machine. Regardless I stopped working on this project soon after my initial post so there’s no additional support needed on my end. Thanks!