OpenMRS Platform installation - No User Interface message

(Anne V) #1

Application Name: Platform + Reference Application modules Version Number: 2.0.5

Question: Hi everyone, I’m new to OpenMRS, so please forgive me if these are basic questions… I’ve just installed OpenMRS Platform Enterprise, plus all modules from the Reference Application on my machine. But upon startup, it keeps displaying that I don’t have a User Interface. I’ve followed the instructions to copy the .omod files to the modules directory (located in the same location as my openmrs-runtime.properties file). Here are my specs:

  1. Running Windows Server 2003
  2. Java 1.8.0_151
  3. Tomcat 6.0
  4. MySQL 5.6
  5. OpenMRS Platform Enterprise 2.0.5
  6. OpenMRS Reference Application modules 2.6.1

When I start OpenMRS, I see a message “OpenMRS Platform 2.0.5.9f9213 Running!”, but there is no User Interface. But I’ve followed the instructions to install legacyui as well as all modules from #6 above. All .omod files are copied to C:\WINDOWS\system32\config\systemprofile\Application Data\OpenMRS\modules. I confirm that openmrs-runtime.properties is also located at C:\WINDOWS\system32\config\systemprofile\Application Data\OpenMRS, as well as openmrs.log, which is written to upon startup. I’ve also restarted Tomcat. I’ve also tried to install the Reference Application standalone version, and this also gives me the same message that it’s running successfully but has not User Interface.

Could someone please help? Thank you!

1 Like
(Samuel Male) #2

Oooohh sorry for this. I think you may have a look at this https://wiki.openmrs.org/display/docs/User+Interface+Modules

(Daniel Kayiwa) #3

With the mouse in your browser address bar, can you press CTRL + SHIFT + R and tell us what happens?

1 Like
(Anne V) #4

Hi All, When I press CTRL+SHIFT+R, I get the same screen. I did follow the instructions on https://wiki.openmrs.org/display/docs/User+Interface+Modules. I installed legacyui as well as all modules in the Reference Application, but I’m still seeing the same results. The openmrs.log seems to suggest that the modules are being loaded, though. Thanks!

(Daniel Kayiwa) #5

Can you clear your browser cache?

(Anne V) #6

Have cleared the cache as well. BTW, I am using Chrome - is that a problem? Thanks

No User Module Installed Error
(Daniel Kayiwa) #7

Can you paste your tomcat log at pastebin.com?

(Anne V) #8

Will do when I get home from work tonight (in about 5-6 more hours). If there is anything else that you feel would be useful to see, please let me know so that I can prepare all of this for you tonight. Thanks

(Anne V) #9

Hi Daniel, I’ve pasted the following logs at https://pastebin.com/VtbFs1B6: Tomcat: stdout.log, jakarta_service.log, catalina.log, manager.log, localhost.log OpenMRS: openmrs.log, liquibaseUpdateLogs.txt

All of these were cleaned prior to my last attempt at redeploying OpenMRS again, so the logs should be compact. Furthermore, each log is separated by “*********************************” for easy readability. Please let me know if you need anything else. Thanks for the help!

(Dimosthenis Kolokythopoulos) #10

Dear Avo, I think I solved the problem try the system and user variables as described in this v2.0 Implementation Documentation. That solved my problem.

(Daniel Kayiwa) #11

The pastebin link says, This page has been removed! Am also assuming that you have tried more than one browser and still get the same behavior.

(Samuel Male) #12

If the above is blocking you, you may want to try this.

(Anne V) #13

Hi All,

Yes, my logs were removed from pastebin. I guess they didn’t like what I pasted???

I tried following tenios’ instructions for setting up the environment variables and restarted tomcat/openmrs. I got the same message. I then went to the URL and typed ctr-shift-r and got the following. Hope this helps a little:

The following error occurred at startup: Unable to start OpenMRS. Error thrown was: org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘reportingSerializer’ defined in URL [jar:file:/C:/WINDOWS/system32/config/systemprofile/Application%20Data/OpenMRS/.openmrs-lib-cache/reporting/lib/reporting-api-1.12.0.jar!/moduleApplicationContext.xml]: Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException: Failed to instantiate [org.openmrs.module.reporting.serializer.ReportingSerializer]: Constructor threw exception; nested exception is java.lang.NoClassDefFoundError: net/sf/cglib/proxy/Enhancer org.openmrs.module.ModuleException: Unable to start OpenMRS. Error thrown was: org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘reportingSerializer’ defined in URL [jar:file:/C:/WINDOWS/system32/config/systemprofile/Application%20Data/OpenMRS/.openmrs-lib-cache/reporting/lib/reporting-api-1.12.0.jar!/moduleApplicationContext.xml]: Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException: Failed to instantiate [org.openmrs.module.reporting.serializer.ReportingSerializer]: Constructor threw exception; nested exception is java.lang.NoClassDefFoundError: net/sf/cglib/proxy/Enhancer at org.openmrs.web.WebDaemon.startOpenmrs(WebDaemon.java:65) at org.openmrs.web.Listener.contextInitialized(Listener.java:194) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4135) at org.apache.catalina.core.StandardContext.start(StandardContext.java:4630) at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791) at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771) at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:546) at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:637) at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:563) at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:498) at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1277) at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:321) at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119) at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053) at org.apache.catalina.core.StandardHost.start(StandardHost.java:785) at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045) at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:445) at org.apache.catalina.core.StandardService.start(StandardService.java:519) at org.apache.catalina.core.StandardServer.start(StandardServer.java:710) at org.apache.catalina.startup.Catalina.start(Catalina.java:581)…

(Dimosthenis Kolokythopoulos) #14

Dear Evo sorry to bother you but I had a similar message. What I did was to erase the whole OpenMRS installation (from Apache and c:/windows/system32/config/systemprofile/ ) plus database plus logs and reconfigure everything. If we accept that we both have similar configuration (windows server, apache, mysql, java) and if we both had forseen variables I dont see why it did not work fow you. I would suggest to insist. The interface problem troubled me for a week and so. It was a pure lack that I found the link and decided to try it before dropping down the whole OpenMRS. Best luck.

(Anne V) #15

Hi All,

Just a quick update. I re-deployed OpenMRS again and copied over the .omod files as well. This time, when I go to the url bar and type in ctrl+shift+r, I no longer get an error message, but I still get the “no user interface” message.

Since I am unable to use pastebin, here are some errors that I see in the logs:

openmrs.log:

WARN - Module.expandExtensionNames(546) |2017-11-28 12:09:45,503| fhir: Unable to find class definition for extension: org.openmrs.admin.list java.lang.NoClassDefFoundError: org/openmrs/module/web/extension/AdministrationSectionExt at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:763) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) at java.net.URLClassLoader.defineClass(URLClassLoader.java:467) at java.net.URLClassLoader.access$100(URLClassLoader.java:73) at java.net.URLClassLoader$1.run(URLClassLoader.java:368) at java.net.URLClassLoader$1.run(URLClassLoader.java:362) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:361) at org.openmrs.module.ModuleClassLoader.loadClass(ModuleClassLoader.java:637) at org.openmrs.module.ModuleClassLoader.loadClass(ModuleClassLoader.java:556)


tomcat stdout.log:

WARN - IdgenTask.run(32) |2017-11-28 12:17:01,883| Not running scheduled task. DaemonToken = null; enabled = false WARN - SimpleUrlHandlerMapping.registerHandlers(115) |2017-11-28 12:17:13,364| Neither ‘urlMap’ nor ‘mappings’ set on SimpleUrlHandlerMapping INFO - ServiceContext.doneRefreshingContext(827) |2017-11-28 12:17:13,926| Done refreshing Context Exception in thread “Thread-10” java.lang.NoClassDefFoundError: javax/servlet/ServletRegistration at java.lang.Class.getDeclaredMethods0(Native Method) at java.lang.Class.privateGetDeclaredMethods(Class.java:2701) at java.lang.Class.getDeclaredMethods(Class.java:1975) at org.springframework.util.ReflectionUtils.getDeclaredMethods(ReflectionUtils.java:571) at org.springframework.util.ReflectionUtils.doWithMethods(ReflectionUtils.java:490) at org.springframework.util.ReflectionUtils.doWithMethods(ReflectionUtils.java:474) at org.springframework.beans.factory.annotation.AutowiredAnnotationBeanPostProcessor.determineCandidateConstructors(AutowiredAnnotationBeanPostProcessor.java:241) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.determineConstructorsFromBeanPostProcessors(AbstractAutowireCapableBeanFactory.java:1057) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBeanInstance(AbstractAutowireCapableBeanFactory.java:1030) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:504) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:476) at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:303) at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:230) at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:299) at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:194) at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:762) at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:757) at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:480) at org.openmrs.module.ModuleUtil.refreshApplicationContext(ModuleUtil.java:842) at org.openmrs.module.web.WebModuleUtil.refreshWAC(WebModuleUtil.java:866) at org.openmrs.web.Listener.performWebStartOfModules(Listener.java:658) at org.openmrs.web.Listener.performWebStartOfModules(Listener.java:637) at org.openmrs.web.Listener.startOpenmrs(Listener.java:268) at org.openmrs.web.WebDaemon$1.run(WebDaemon.java:42)

tomcat localhost.log:

Nov 28, 2017 12:09:45 PM org.apache.catalina.core.StandardContext listenerStop SEVERE: Exception sending context destroyed event to listener instance of class org.openmrs.web.Listener java.lang.NullPointerException at sun.reflect.UnsafeFieldAccessorImpl.ensureObj(UnsafeFieldAccessorImpl.java:57) at sun.reflect.UnsafeObjectFieldAccessorImpl.get(UnsafeObjectFieldAccessorImpl.java:36) at java.lang.reflect.Field.get(Field.java:393) at org.openmrs.util.MemoryLeakUtil.shutdownMysqlCancellationTimer(MemoryLeakUtil.java:42) at org.openmrs.web.Listener.contextDestroyed(Listener.java:604) at org.apache.catalina.core.StandardContext.listenerStop(StandardContext.java:4174) at org.apache.catalina.core.StandardContext.stop(StandardContext.java:4778) at org.apache.catalina.manager.ManagerServlet.stop(ManagerServlet.java:1327) at org.apache.catalina.manager.HTMLManagerServlet.stop(HTMLManagerServlet.java:642) at org.apache.catalina.manager.HTMLManagerServlet.doGet(HTMLManagerServlet.java:138) at javax.servlet.http.HttpServlet.service(HttpServlet.java:617) at javax.servlet.http.HttpServlet.service(HttpServlet.java:717) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:563) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:857) at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588) at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489) at java.lang.Thread.run(Thread.java:748)

(Daniel Kayiwa) #16

@avo can you use pastebin.com for your logs to make it easier to read this thread?

(Anne V) #17

Hi dkayiwa,

I did use pastebin, but they removed it for some reason.

(Daniel Kayiwa) #18

You can try again.

(Anne V) #19

Hi dkawayiwa,

I’ve reposted it: https://pastebin.com/945gLtyp

Thanks

(Daniel Kayiwa) #20

Did you also install the legacyui module?

Can you try tomcat versions from 7 and above?