openmrs-core installation wizard

Hello every one ;

I am running the openmrs installation with ‘mvn jetty:run’ command, in the browser on the installation wizard i was given three option ie simple,advanced, and testing… Which option should i opt for ?



1 Like

As you try to learn about OpenMRS, you will not lose anything, if you explored those options and see how far they take you.

1 Like

thanks @dkayiwa let me explore all the options and see how far they take me

The options also give pointers to where they lead…Advanced will be a good place to checkout…

yes thanks @reagan i have tried it out to

@dkayiwa i have explored the options as you recommended and this is how far it has taken me with all the options i come to this interface here.

i wanted to inquire if this is how far running the platform alone can take me ?

you can go on and install the user interface module as per the guide lines on that page

yes @herbert24 i did that but still getting the same issue

when you check this, you can install the reference application or legacy ui module and get the server restarted.This should fix that.

i deployed the omod file of the latest legacy UI module and did get that interface above

Have you tried refreshing the page? Without restarting the server?

ya i refreshed but am seeing the issue being more about why user interface is not popping up

Have you installed any modules?

yes @dkayiwa i dropped the omod files of the legacy UI, rest webservices, and fhir in the modules folder before running the server

What is the full path of that folder?


Can you share your log at

@dkayiwa it is here

I mean that section of the log which has this text Using runtime properties file:

@dkayiwa here is the section