openmrs-contrib-qaframework build failure .

@achilep unfortunately i can tell much from the logs you have shared ,i need the full logs for the failure you have gotten while cloning but with that said you need to try again to clone and do a successful build on branch 2.10.0

1 Like

thanks @gcliff . I finally succeed.

1 Like

I have tried to follow the solutions in the chat @gcliff and @achilep but am still getting some errors like in the logs here is there anything I can change

@insookwa first cd back in to the master branch and do a git fetch --all followed by git pull --rebase upstream master

  1. Then cd again into branch 2.10.0 and do a git reset --hard upstream master followed a git pull --rebase upstream master and run mvn clean install

I have done it all but Now I think I have an issue with git help me out, please C:\Users\Insookwa\openmrs-distro-referenceapplication> git reset --hard upstream master fatal: ambiguous argument ‘upstream’: unknown revision or path not in the working tree. Use ‘–’ to separate paths from revisions, like this: ‘git […] – […]’

1 Like

@insookwa can you share the complete log message?

@achilep it here I had staggered a lot trying to fix it :grinning:

1 Like

@insookwa run mvn clean install and share your output.

1 Like

Thanks, @achilep here is the error log I have tried and this is the error

1.git clone

2.git checkout 2.10.0

3.mvn clean install.

'4. git clone

5.git checkout bdd

6.mvn clean install

7.git clone

'8. mvn clean test

@insookwa can you follow this step ?


Thanks, @achilep this helped. everything is running fine :smile:


I am getting this error when i do MVN CLEAN TEST on QA framework. i have deleted the chrome driver in the error and deleted logs but there is test failure still. is something wrong error logs here : @k.joseph @achilep

What happens when you restart your computer?