openmrs-contrib-qaframework build failure .

hello, I am getting this error with qaframework : https://pastebin.com/6eH4PP62 is due to org.openmrs.distro: referenceapplication-ui-tests : 2.10.0 dependencies, it’s not available on maven.

cc: @k.joseph

@achilep, can you clone and compile that locally?

2 Likes

following this guide would do you well and as well offer more feedback about it’s processes

1 Like

yes, I have done this. but I didn’t build openmrs-contrib-uitestframework .

I will start the process all over again.

@k.joseph I follow this guide https://wiki.openmrs.org/pages/viewpage.action?pageId=235277297 but i am getting the same error . The problem is with the dependencies.

@achilep try to do a git fetch --all and then maven build again

1 Like

thanks, @gcliff but it didn’t work.

try to force updated in the maven build with mvn clean install -U

1 Like

Also have you compiled the UITestFramework on the bdd branch before compiling the QAFramework?

I am getting the same error.

1 Like

yes, and it builds successfully.

1 Like

I have done a maven build here and got a different failure which is probably due to the chrome driver version am using that needs to be fixed

1 Like

@achilep https://pastebin.com/hseM1zvR

1 Like

please @gcliff can you delete the contents of this directory: .m2/repository/org/openmrs/distro/referenceapplication-ui-tests and run this : mvn dependency:tree again .

:sweat_smile: I am not the only person with this issue.

1 Like

@gcliff you compiled it successfully because this dependency is already present on your computer. I’m sure if you delete the dependencies from your local computer you will get the same error.

cc: @k.joseph @sharif

@achilep try out these steps

git clone [git@github.com](mailto:git@github.com):openmrs/openmrs-distro-referenceapplication.git

git checkout 2.10.0

mvn clean install

and then compile the QA framework again

1 Like

@gcliff this is the output .

kindly share the logs here https://pastebin.com/

1 Like

error log: https://pastebin.com/raw/5jYw3YfS

1 Like