OpenMRS 3.x docker image backend not running.

Hi all. I was trying to run this docker image openmrs-distro-referenceapplication/docker-compose-distro.yml at 3.x · openmrs/openmrs-distro-referenceapplication · GitHub in GitHub - openmrs/openmrs-distro-referenceapplication at 3.x branch. The front-end is working fine on my machine but it getting a blank page because the backend throws some errors and it’s not working.

later it worked fine for me before the latest commits were made to the 3.x branch.

This is the backend error log:

Also, I referred to this thread which talks about the issues related to Apple m1 architecture because I’m also using the Apple M1 :

I tried by destroying the associated volumes with docker compose down -v command. But the issue still occurs.

I think @jayasanka is also facing the same issue.

cc: @ibacher @raff

2 Likes

This is the issue I guess:

org.apache.catalina.startup.SetContextPropertiesRule.begin [SetContextPropertiesRule]{Context} Setting property 'antiJARLocking' to 'true' did not find a matching property.

PS: Just found out that antiJARLocking has been removed in Tomcat 8.

@bistenes We need to sort this out as it is a blocker @pasindur2 is facing right now.

Btw, @pasindur2 Could you please run the server manually and fix existing tests until we get this fixed?

You have a few options:

  1. Checkout to a previous commit and package it again.
  2. Use the SDK
  3. Manually deploy the war file. (Get @anjisvj 's help. He did it recently)

Btw, @pasindur2 did you run docker compose build?

Sure I’ll work on that.

Yeah, I build it before running.

The stacktrace indicates that it hasn’t completed starting up. The antijarlocking should not be the issue. It feels that it is just extremely slow due to not using the arm image of openmrs-core. I will try to adjust our CI to build arm today. I will update you once done.

3 Likes

Thanks @raff.

We now have arm64 images for openmrs-core, see Docker Hub

Please try docker compose build again and let us know if it works.

It works fine. :partying_face:

Thank you very much @raff !

But some components such as patient registration is not loading.

The error says Found modules with unresolved backend dependencies . Is this issue related to this?

cc : @raff @jayasanka

Sorry for bothering you. The issue is resolved and it’s not related to this docker issue. Thank you. @jayasanka @raff

@pasindur2 i also found out that the Found modules with unresolved backend dependencies error message is not related to this docker setup. How did you resolve it?

Actually, the error message still occurs but for 3.X patient registration e2e testing, the wanted components are working. That’s why I pointed out here that the issue is fixed for me. @dkayiwa

1 Like