Multi-select obs with add-more property published from form-builder is not working properly

form-builder
Tags: #<Tag:0x00007efd1e8ab818>

(Siav R) #1

Hello, I’ve created a form from from-builder with an obs with properties multi-select and add-more. When I fill obs from consultation page, values are not getting saved. Look at the following example

Step 1: Filled two values and saved.

Step 2: Click on add-more and fill a value(not saved yet)

Step 3: Click save on above state

The expected behavior is the second obs should be available. We have observed that data is also not getting stored in the database.

This is one of the scenarios I’ve depicted where multi-select works in a weird way.

Is anybody using this feature?

@angshuonline @swathivarkala @binduak @darius @pramidat


Bahmni PAT call Nov 28th 2018
(Siav R) #2

Correct me if I’m wrong. You can’t make a concept both multi-select and addMore in forms 1.0(It didn’t work for me means only one behavior is working).

So in forms 2.0 we should restrict to select either multi-select or add-more in implementer-interface. So forms 1.0 and forms 2.0 will behave in same fashion.


(Angshuman Sarkar) #3

Why would you want to have “Addmore” for a concept which already accepts multiple values? I don’t mind if we don’t allow addmore for multiselect elements.

Btw, have you tried the same behavior setting in Forms 1?


(Siav R) #4

I was playing with form builder multi-select since it allowed both multi-select and add-more in implementer-interface.

I’ve tried to make a concept both multi-select and add-more in forms 1.0. The only behavior I see is multi-select every time(irrespective of the order of multiselect and addMore config). I’ve tried with following config in App.json

"P/A Presenting Part": {
     "multiSelect" : true,
     "allowAddMore": true
},

(swathi varkala) #5