JIRA/issues.openmrs.org migrated!

Happy to announce that JIRA (issues.openmrs.org) has been migrated!

Thanks to all who contributed and helped in any way with the migration effort. Special thanks to @jayasanka for leading us most of the path and coming up with the right setup and proof of concept.

We have deployed a new SSO solution to keep OpenMRS ID accounts. In order to login please go to issues.openmrs.org and follow the login instructions. Your OpenMRS ID account is now available on Atlassian cloud services by using your OpenMRS e-mail alias your_openmrsid@id.openmrs.org.

Please remember that this e-mail alias is for login purposes and OpenMRS services only. It can not be used as a regular e-mail alias and any private e-mails sent to that address will be rejected.

If you encounter any issues, please report them back as a reply to this post.


This is awesome!!! :star_struck: :partying_face: :clinking_glasses: :tada: Thanks a lot on working on this, Raff! :heart:

The JIRA dashboard threw some “something wrong errors” when I logged in first. However, when I visit the issues.openmrs.org again, it popped me the initial onboarding steps, and now everything works like a charm.

The forgot password isn’t working. It seems the SMTP credentials hasn’t yet added to Keycloak.


Bravo Raff and Jayasanka!! You have both done so much work to get us here, and special thanks as well to @burke, @cintiadr and @ibacher who pitched in to help with SSO architecture review, testing, and a variety of other things :heart: :clap: :bouquet:

Great catch Jayasanka on the password reset check.

@raff I’ve found 1 main issue; maybe this will be resolved by the work you already have planned for this Tuesday? The Project Views are not all there as expected. Maybe this is also due to my current @id.openmrs.org access level?

Old Project View Options (I use Backlog and Release the most often)

New Project View Options (Not many…)

What I see when I try to edit the Project Settings:

1 Like

I cannot login . with my tendomart@id.openmrs.org and my old password

I fixed resetting the password so you might want to do that. Please note that when you land on id-new.openmrs.org, you login as usual with your OpenMRS ID i.e. tendomart. The e-mail alias tendomart@id.openmrs.org is only needed in Atlassian.


@grace you are an admin on the O3 project. Please make sure that you are logged in with your grace@id.openmrs.org account and not grace@openmrs.org. Just click your avatar icon in the top-right corner in JIRA, choose logout and login to another account. Please let me know if it fixes the issue.

@raff yep I’m signed in with my id.o address, but this is still what I see. Seems I don’t have full permissions? I can tweak some things, but not what’s needed to add the Board views we need.

It’s strange. The message says you are not JIRA Software user, but you are… Please recheck now that I adjusted permission schemes to include migrated project roles. If it didn’t help then we need to contact Atlassian’s helpdesk.

1 Like

Thanks @raff for the great work. I have successfully logged into jira/issues but am unable to change the ticket status from in progress to done neither am I able to view a ticket. Kindly how can I go about it?

I faced exactly the same problem untill when i logged out of dkayiwa@openmrs.og and then logged in again via dkayiwa@id.openmrs.org


Thanks so much for the help and guidance. It has worked pretty well!


Whatever you did @raff unblocked me - thank you!!

I can now see the Backlog view I so love :smiling_face_with_three_hearts:

And I updated the short-link so now anyone with an account should be able to see the O3 RefApp backlog screen by going to: Log in with Atlassian account


Hi! I’m Subhradeep. I want to login to jira/issues but I’m unable to. How to I get my_id@id.openmrs.org?

Hello, I was trying to login to jira/issues but it asks for a code. I don’t know where to get that code from This is my id poulavb@id.openmrs.org

@raff when i log in with your_openmrsid@id.openmrs.org, i no longer get the second screen that used to come up for entering the OpenMRS ID and password. I instead just get asked for the password for your_openmrsid@id.openmrs.org

Could something have got broken?

I just checked and Atlassian dropped our Atlassian access identity provider config for some reason. I tried recreating, but it says something went wrong. I will reach out to Atlassian for help…

Hello @raff Can you let us know by when can this thing be fixed, so that we can get access to the jira platform

Of course, I will let you know as soon as we have some resolution. It’s a holiday period so it’s taking a bit longer…

Alright sir, no problem!