Issues with cloning OpenMRS core tag 2.3.0

I am on mac and cloned open mrs for tag 2.3.0

git clone
git checkout -b testing-2.3.0 2.3.0

I am getting following issues after hitting th URL :-

**java.lang.IllegalArgumentException** : **Locale part "en-GB" contains invalid characters**
**at** org.springframework.util.StringUtils.validateLocalePart ( **** )
**at** org.springframework.util.StringUtils.parseLocaleString ( **** )
**at** org.springframework.web.servlet.i18n.CookieLocaleResolver.parseLocaleCookieIfNecessary ( **** )
**at** org.springframework.web.servlet.i18n.CookieLocaleResolver.resolveLocaleContext ( **** )
**at** org.springframework.web.servlet.DispatcherServlet.buildLocaleContext ( **** )
**at** org.springframework.web.servlet.FrameworkServlet.processRequest ( **** )
**at** org.springframework.web.servlet.FrameworkServlet.doGet ( **** )
**at** javax.servlet.http.HttpServlet.service ( **** )
**at** org.springframework.web.servlet.FrameworkServlet.service ( **** )
**at** javax.servlet.http.HttpServlet.service ( **** )
**at** org.eclipse.jetty.servlet.ServletHolder.handle ( **** )

Environment :-

Java version: 1.8.0_242, 
Default locale: en_GB, 
platform encoding: UTF-8
Apache Maven 3.6.3 (cecedd343002696d0abb50b32b541b8a6ba2883f)

@ibacher @dkayiwa Could you please help me out with the issue.

What is your Java -version, and maven version

Updated the same

What java version are you using currently, what is java -version and mvn -v on command line

java -version

openjdk version "1.8.0_242"
OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_242-b08)
OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.242-b08, mixed mode)

mvn -v

**Apache Maven 3.6.3 (cecedd343002696d0abb50b32b541b8a6ba2883f)**
Java version: 1.8.0_242, vendor: AdoptOpenJDK, runtime: /Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home/jre
Default locale: en_GB, platform encoding: UTF-8
OS name: "mac os x", version: "10.15.3", arch: "x86_64", family: "mac"

Can you try cloning openmrs core 2.4.0-snapshot which is the current version

you mean checking out from master. Right?

Yes, getting full openmrs-core master from git

I tried with that as well. However, there are lot more issues with that in comparison.

spring-beans-5.2.4.RELEASE means you are running the master changes. 2.3.0 has

@dkayiwa Yeah I know that. So, I started this thread with issue I was facing on 2.3.0

It was just on the suggestion of @sharif that I tried with master.

So, issue at the top is with 2.3.0

I have made some more commits to the master branch and a couple of modules, as a result of your reports. So if you are doing all this for learning purposes, i would be glad if you can give me a helping hand by simply trying the master branch again. It greatly helps to have more than one pair of eyes. :smile:

1 Like

I already have the changes you committed 12 hours ago. I can help with this thing, it’s not an issue. However, I need at least one version running for development and testing workflow of open mrs. So, if you could please provide me with specific branch/tag which will work fine (along with other dependent modules like registration core, legacy ui etc) I would be glad.

The easiest way of doing that is use the OpenMRS SDK

Choose Distribution and then select reference application version 2.9.0

Well I’ve tried that as well. The issue I was getting was :slight_smile:

This locale issue… Is this with mac only?

Which browser are you using?

1 Like

Chrome. Should it affect?

Do you get the same exact error if you try another browser?

Well there you got it :slight_smile: . No I am not getting that error with Safari.