Issue in Offline installation of OpenMRS 2.0.1 in Tomcat

Hi, Whenever I try to install 2.0.1 build in Tomcat with no internet connectivity. But it gives following error

"ERROR - Listener.performWebStartOfModules(671) |2017-03-28 12:17:33,833| Unable to refresh the spring application context. Root Cause was: " It works fine when there is Internet connectivity. But when I remove internet connectivity and tried again, it gives above error again.

Anyone has any idea around it?

I have tried few solutions mentioned in this link, but couldn’t get it.

@sagarbele The reason for that probably is that there are some dependencies which need to be downloaded when you install it for the first time. Please let the internet be on initially and once it’s installed,I’m sure you are able to run it offline :slight_smile:

@sagarbele, thanks for reporting!

We need to fix that. Let’s identify, if it comes from openmrs-core or some module. Where did you get the war from? Did you add any modules?

Hi Reuben, I tried that, but same result when I tried second time with no internet connectivity on same machine.

@raff , Yes there additional modules. I got the openmrs code from github released version 2.0.1 in tags.

I did not get any error while running only build of 2.0.1. But with following attached modules, I am getting this error. ModuleList.docx (17.6 KB)

It’s a long list of modules… Could you please try to identify which one is causing the issue?

I’d approach it by running only half of them. If it works, the problematic module is in the other half. If not, then the problem is in the current half, which you need to further divide by half and so on. Please check each time if all modules you are currently checking have actually started, because some of them may require other modules, which you will need to start. I know it’s tedious, but it will help you to identify the culprit…

Sure. Will try with this approach

@sagarbele this could be caused by the jasperreports module. I have created a pull request here for you to confirm if it is:

cc @ibewes

@dkayiwa thanks. Issue resolved.