Installing UI for developement purpose

I have cloned the repo open-mrs-core. After cloning I ran the following command mvn clean install and mvn jetty:run. The server ran successfully. after going to http://localhost:8080/openmrs/ it is saying to install a user interface module. The URL it redirects to is openmrs-module-legacyui repository. My major concern is did I installed the right repo for development purpose and Is openmrs-module-legacyui is the right UI for openmrs.

If the main purpose for cloning the repository is development, kindly go to your IDE and import the project but ensure you are working on a branch but not the master.

I have installed legacy UI by following the steps mentioned in the developer guide. But I’m getting this error don’t know what to do now HTTP ERROR 500 javax.servlet.ServletException: org.apache.jasper.JasperException: /WEB-INF/view/index.jsp (line: [1], column: [1]) Unable to find taglib [c] for URI: [/WEB-INF/view/module/legacyui/taglibs/c-rt.tld]

do you mind running the OpenMRS server usng a standalone or the SDK ?? its much simpler for you especially getting familiar with OpenMRS

@mozzy Is standalone or SDK is good for developement purpose?

1 Like

its very ok. Ideally the SDK is the best OpenMRS development tool , the standalone is majorly for getting around OpenMRS at first time , however you can still use it for dev porposes

@sachinmukherjee could have a look through at this

@mozzy I tried to run the openmrs-sdk but test cases failed

[INFO] OpenMRS SDK ........................................ SUCCESS [ 0.428 s]

[INFO] OpenMRS Reference Application Module Maven Archetype SUCCESS [ 1.328 s]

[INFO] OpenMRS Platform Module Maven Archetype ............ SUCCESS [ 0.823 s]

[INFO] OpenMRS OWA Submodule Maven Archetype .............. SUCCESS [ 0.060 s]

[INFO] OpenMRS SDK Docker Maven Plugin .................... SUCCESS [ 4.340 s]

[INFO] OpenMRS SDK Maven Plugin ........................... SUCCESS [ 9.806 s]

[INFO] OpenMRS SDK Integration Tests ...................... FAILURE [03:38 min]

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.22.1:test (default-test) on project openmrs-sdk-integration-tests: There are test failures.

[ERROR] Please refer to /home/sachinmukherjee/Coading/OpenSource/openmrs-sdk/integration-tests/target/surefire-reports for the individual test results

@sachinmukherjee , what steps were you trying to do ?? can you try to list all the steps and commands you were trying out ??

1 Like

@mozzy There are the steps I followed

  • Cloned the repository openmrs-sdk.

  • Ran the mvn clean install command inside openmrs-sdk directory.

oh no , doing that would mean you want to do developmnet on the SDK its self ,

kindly follow this for installation and usage

@mozzy By using this link Will I be able to use the openmrs for development purpose?

What kind of project would you like to create?:

  1. Platform module
  2. Reference Application module
  3. Open Web App

Which option should i choose from the above three for developement purpose?

it depends on what you want to develop . What do you want to do at first …

But whats the difference between these three?

you can take a look at this post

1 Like

So I have followed all the points and installed Reference Application module. A folder name basicexample is been created. My main concern is how should I used the basicexample folder for development purpose. Plus their is error in home page