Installing OpenMRS on Docker(Resolved)

How do we install openmrs locally on linux os using a docker. Have recently been using standalone but seemingly to be slow with my pc. I want to have a running openmrs reference application for testing purposes. Hoping running openmrs using a docker would give me a better performance

Is this of help Installing OpenMRS on Docker - Documentation - OpenMRS Wiki

Do you mean the startup time? If yes, does this make any difference? https://ci.openmrs.org/build/result/artifactUrlRedirect.action?planKey=REFAPP-OMODDISTRO&buildNumber=10962&artifactName=referenceapplication-standalone-snapshot

1 Like

I followed that page but on the attempt to run this command $ docker run -it --rm -p 8080:8080 openmrs/openmrs-reference-application-distro:demo it took almost an hour and could not finish. Not sure whether that wiki is up to date since it appears to have been updated in 2015-10-11

Not sure about its performance. Have tried to download but its seems it requires a good band width. The download time as per my view indicates 3 days left for the download to be complete.

Alternatively, you can use the SDK and select the 2.12.0-SNAPSHOT distribution.

atfirst it takes some time to download the image .but that happens once. Almost an hour could imply a slow network on your side .

Could there be success here

opensource@opensource-OptiPlex-3010:~$ docker run -d --name openmrs -p 80:8080 openmrs/openmrs-reference-application-distro
Unable to find image ‘openmrs/openmrs-reference-application-distro:latest’ locally
latest: Pulling from openmrs/openmrs-reference-application-distro
c5e155d5a1d1: Already exists
221d80d00ae9: Already exists
4250b3117dca: Already exists
d1370422ab93: Already exists
deb6b03222ca: Already exists
9cdea8d70cc3: Already exists
968505be14db: Downloading 118.4MB/118.4MB
04b5c270ac81: Download complete
301d76fcab1f: Download complete
ddf85cd1cc29: Download complete
ef1e6f25e812: Download complete
ec33c4228e80: Downloading 183.6MB/183.6MB
f80b7f1b28a1: Download complete
fea2431ce424: Download complete
d6a7b0de6138: Download complete
f0245fd4dc2d: Download complete
42b1d969be60: Download complete
9bf34f3f57eb: Download complete
d7bf4296515d: Download complete
8f41f79129e8: Download complete
docker: unexpected EOF. See ‘docker run --help’.
opensource@opensource-OptiPlex-3010:~$ docker logs openmrs
.Error: No such container: openmrs
opensource@opensource-OptiPlex-3010

to make docker configurations easier ,use docker compose . checkout
Option 3 - Running MySQL and OpenMRS using direct docker-compose
on the same page

yes it shows a great succes in downloading the image artifatcs .

now try using docker compose for spinning up a container .

Its like i need to be in the right directory to this container, am still figuring out its directory. I fired whereis docker and returned docker: /usr/bin/docker /etc/docker /usr/share/docker.io /usr/share/man/man1/docker.1.gz

did you try using docker compose ?? its easier for you doing the configurations.

not really , you can always acces an image or the container from any where .

Could you let me know how Or a command to be fired

Have tried this

@kdaud you need to cd into the directory where your docker-compose file its located and runt the command again

Could this be the reason of not being up to start it
cc: @mozzy

Where exactly should I stand in running the command.

The directory under /usr/bin/docker can not be accessed with some message this is not a dirctory. Navigated to the one that could be accessed and look at the outcome

what are u trying to do? sorry i have just rushed through this

I wanted to install openmrs server using docker image hoping its lighter to give my pc a better performance for testing purposes. However have opted for SDK following this OpenMRS SDK - Documentation - OpenMRS Wiki