Installing modules

Hi everyone,

I’ve deployed the Platform 2.0.1 war on an Apache Tomcat 7 but I get the advice shown in the photo

I have downloaded the ‘Reference Application 2.5 Modules & Data’ and I copied all the modules in the folder ‘modules’ allocated in the /var/lib/OpenMRS directory, where the file is allocated.

Then, when I restart the tomcat and go to the web application there is no answer and the host doesn’t do anything. Could be this a consequence of the low processing power of the server (I’m using a Raspberry Pi 3)?

As I don’t know perfectly how does the modules work, I wanted to know which are the main modules necesaries to make openmrs work and if the path /var/lib/OpenMRS/modules is the correct place to copy the modules.

Did the server start correctly? Are you receiving the above message now or before the module installation?

If your runtime properties file is in /var/lib/OpenMRS then your modules should be in /var/lib/OpenMRS/modules After pasting the modules, restart tomcat. If you still have the same page, then try press CTRL + SHIFT + R from the browser address bar.

The server is correctly started. I have copied all the modules into the modules folder but when I get to the web application the server doesn’t respond. Here I show all the modules I have and the status of the server:

The problem is that when I pasted all the modules the server doesn’t respond.

Which are the main modules that I have to have installed in order to run successfully the openmrs? I only want the necessary modules to get the openmrs running. I have pasted all the modules downloaded here: and maybe my machine can afford all processing power that need all these modules in order to run them.

I have never tried this, but I would be surprised if you are able to run OpenMRS core + many modules on a Raspberry Pi.

You should look at the tomcat logs and see if they give you any insight into what’s going on.

The thing is that I want to run OpenMRS with the basic modules and I don’t know if all the modules provided in the link are all necesary or maybe I can ommit some of them

I believe the minimum is just openmrs-core + legacyui module.


1 Like

I’m a newbie too. I got to the same point after installing OpenMRS-core. To get beyond that I successfully installed LegacyUI, but only after trashing everything and starting all over! Then I had problems uploading HTML formentry modules, as when I did I was then unable to connect to localhost:8080. After reading a number of posts I decided I needed openmrs-sdk (while it seems some people have no problems doing so, I now find I’m stalled because I cant get a connection to my database!).

You also trying it on a RasberryPie?

I’m on mac osx

Hi everyone once again,

I have been able to run the application installing the following modules: Legacy UI Module,Core Apps Module,App Framework Module,App UI Module,OpenMRS UI Framework,EMR API Module,Rest Web Services OMOD,ID Generation ,Reporting,UI Commons Module,Provider Management Module,Metadata Sharing,Event Module,Serialization Xstream,Calculation,HTML Widgets,UI Library Module,Metadata Mapping.

I have been able to start all these modules except one, Core Apps Module, which throw the following error: Unable to load/find moduleActivator: ‘org.openmrs.module.coreapps.CoreAppsActivator’ Module: Core Apps Module

Does anyone know why is unable to start the module? I have downloaded the newest version of this module from the modules page

Thanks in advance

Can you paste the contents of the tomcat log at

Hi, I paste the 3 different log files I have because I don’t know which one you wanted.




Am assuming you do not have any more or modified modules from the ones you downloaded for reference application 2.5 I also assume you are using tomcat7 If yes, stop tomcat, then delete your tomcat/work folder, and start tomcat again.

Yes, I only have the modules downloaded for reference application 2.5 and I’m using tomcat 7.

I’ve tried to stop, delete the tomcat/work folder and start tomcat again, but the same error is happening.

Did you manage to get a solution to this? Facing the same error with core apps module.

Anyone found a solution for above. When i put all the modules, the server give errors. When i remove everything and just keep the legacy mode it works.