Installation Issues

Hello, I am starting up a free clinic in my area and we’re interested in using OpenMRS. I am working from a 2019 MacBook Pro with Ventura 13.4 and navigated to the following link for installation: Download. I tried the reference application 2.12 - both the standalone edition & advanced installation. To my understanding, the standalone edition is a demo version and the advanced installation is purposed for actual patient charting.

After having tried to install both, I found the instructions hard to follow. For example, I downloaded the standalone edition as a zip file. However, I’m not sure where to use the folder generated by the zip file. It seems like additional software is needed but I can’t seem to find it. It would be appreciated if you could share a video on installation for the “advanced installation” version or if we could connect over the phone to work through it.

Is this helpful?

Thank you Daniel. I’m going through the steps right now. Just had a quick question: on Download –, I see reference applications and platform ones. Both standalone editions say that they’re not intended for production use. I understand this to refer to it not being meant for recording actual patient info. Is this the case? If so, is there a “For Dummies” page on how to download Advanced Instillation of the reference application?

As I’m going through installation, I successfully downloaded the zip file, opened it & double-clicked on “openmrs-standalone.jar”. It said this was made by an unidentified developer & I’ve circumvented that by allowing the download in my “Privacy & Security” systems settings on my Mac. Although, after doing so & double clicking the jar file again, it doesn’t download.

Check in the tomcat\logs folder and share the contents of that file via

I tried using & it would only allow me to paste in the same text that displays in the subfolders & their contents. I have two sub-folders under the tomcat\logs folder: conf and webapps. If screenshots are helpful, I’ve included the contents of each sub-folder below:

Here is a screenshot of the 2nd folder, I couldn’t include more than one embedded file in each post:

In the tomcat\logs folder, there is a log file. Open it and copy its contents. Then paste them in and share the paste url.

Is it the file titled “”? When I try opening it, I see this: Screenshot 2024-02-12 at 4.06.54 PM

Can you share a screenshot with the files listed in the tomcat/logs folder?

Yes, here it is:

How many folders do you have under tomcat?

Only two: conf and webapps

Which version of Java is installed on your computer?

I believe it is 1.8.0_391

I’m using a 2019 MacBook Pro with Intel chip. I’m not sure if versions on Mac are different, but I’ve usually seen versions being listed as 8 or 13. Here is where I found “1.8.0_391” on my Mac:

What happens when you open the terminal, change to the unzipped folder, and then run java -jar openmrs-standalone.jar

I’m not that well-versed with development experience so apologies that I have to ask but what are you referring to when you say “terminal”? Also, I do see a jar file but it is only titled “openmrs-standalone.jar” - is this the right one to run?

Do you think you can join the platform team call and get help on this?

Platform Team

When : 8:30pm IST | 6:00pm Nairobi | 5:00pm Cape Town | 3:00pm UTC |10:00am Boston | 7:00am Seattle


Or the earlier daily Coffee Break?

Coffee Break (O3 Troubleshooting for Frontend Developers)

When:5:00 pm IST | 2:30 pm Nairobi | 1:30 pm Cape Town | 11:30 pm UTC | 6:30am Boston | 3:30am Seattle


I definitely can! Just to clarify, this will be on Wednesdays? I’m in Central Time & it seems like the Platform Team call will be at 9am for me & the coffee break at 5:30am. I can try to join on either. Thanks Daniel!

Correct for the platform call. The coffee breaks are from Monday to Thursday.

Or if those times are not convenient, i can jump on a call now, Launch Meeting - Zoom, for a few minutes and i take a look as you share your screen.