How to change default mysql password

Hy, Can i know if i change mysql root and openmrs-user default password using normal password changing method, will it effect for my database connectivity?? What are the other changes need to be do after changing default password,and in which location changes need to be done??? Regards Mithun G

@mithu Have you already changed your password for your mysql and openmrs instance? If so are you able to connect? Usually changing the mysql password does not affect the DB connectivity

@odorajonathan I had tried in vagrant and its effecting my backup process… I had read something like need to change some configuration in some location after changing the default password…I dont know where it is and what are the configurations should change…as a fresher i dont know correctly…

Which version of MySQL are you using?

It is “mysql Ver 14.14 Distrib 5.6.35, for Linux (x86_64) using EditLine wrapper”

Did you accurately follow the steps here? And have you also taken a look at this

1 Like

I am following the same steps which you mentioned there…

Actualy what is my problem is if i change the mysql root and openmrs-user default password ,backup is not running properly…If i again change it into default, backup is running successfully…

I dont know anything need to be change after resetting the default password… @odorajonathan

@dkayiwa @mozzy could you help with this?

1 Like

@mithu, can i get to know which package your running exactly??. are you running standalone or sdk ??

1 Like

And what do you mean default mysql password. do you intend to mean the default password created in the openmrs run-time properties for connecting to mysql??

1 Like

your talking about two different passwords right?

Yes bro…two different users… root and openmrs-user

Yes… The default password created in the openmrs run-time-propertires for connecting to mysql… I had changed the password using normal sql user password changing method… But after that i cant able to take backup… I tried changing password directly in openmrs-runtime-properties also…But after that also,facing the same issue…

Im using Sdk…Version: 2.1.1 Build 725db5 IS using…

can you post your run-time properties here for the exact sdk server thats having issues ??

what do u mean two differet users?? a default user for openmrs and a root user for mysql??

@mithu please clarify which user password changes you mean here, it will be easier to understand what it is that is wrong and where the problem lies.

Users are “root” and “openmrs-user”

are those users accounts for mySQL??

its a matter of setting up your mysql , change the user passwords , and also reflect the same change in your openmrs run-time properties file