How do i use an old database in a new installation ?

Platform Version: 1.11.4

OS: ubuntu 14 and Windows 7, tomcat 8

Question: Hi developpers,

I have installed openmrs 1.11.4 with the default database. And i want to use the database that was installed somewhile ago when one was still using openmrs 1.9.X. How do i do this. I will like to know the steps i need to follow in order to do this ? Thanks

Have you looked at https://wiki.openmrs.org/display/docs/Upgrading+OpenMRS ?

No, Let me look at it and see if it helps. Thanks @k_joseph !!!

Hi developpers @dkayiwa, @michael , @wyclif i followed the example on the page https://wiki.openmrs.org/display/docs/Prepare+for+Upgrading+From+a+Pre-1.10+to+1.10+or+Later+Version and i created the file order_entry_upgrade_settings.txt as required when i run the installation it reads the file but fails with this error

There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201401101647-TRUNK-4187::wyclif: Reason: liquibase-update-to-latest.xml : For input string: "62 " : Caused By: Precondition Error Error while trying to update to the latest database version

Here are some links to the log and the content of my order_entry_upgrade_settings.txt file. http://pastebin.com/X9sXBkKQ http://pastebin.com/4YTezEgf

Please have a look at it i might be helpful.

I would assume that code should be able to trim values, can you try to delete any white spaces after 62

I edited the order_entry_upgrade_settings.txt file and changed the value 62 to something else, that one is not more a problem i presume but the installation still fails with the following message

There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201401101647-TRUNK-4187::wyclif: Reason: liquibase-update-to-latest.xml : Your order entry upgrade settings file does not have mapping for 1/jour x 2 jours/semaine. Please refer to upgrade instructions for more details. : Caused By: Precondition Error Error while trying to update to the latest database version

Meanwhile i have done the mapping for 1/jour x 2 jours/semaine in the order_entry_upgrade_settings.txt file. Here is the link to content of the new order_entry_upgrade_settings.txt file

http://pastebin.com/2AWCJ3eJ

Please have a look at it, may be the syntax is not correct i dont know. Thanks.

  • List item

You need to escape the spaces in the frequencies (the keys) in the order_entry_upgrade_settings.txt file, so 1/jour x 2 jours/semaine would become 1/jour\ x\ 2\ jours/semaine

Ok. Let me do that and get back with the feedback !!!

5 posts were split to a new topic: Error: “orders.orderer column is required as of version 1.10”