Help with installation for developers on windows

Hello guys, I am back again to request help. When my jetty refused to run, i decided to drop everything and start a fresh. Now i did the SDK and its running well. However when i came to installation for developers, i cant find the jetty app. This below is the reply i get. Kindly help

kindly share the installation guide you are working on.

Hello jnsereko thank you for the reply. this is it

hi @brenda29 this url is none existent since 2016. You will need to change it. Though if you follow this wonderful wiki, Set Up Development Environment (Backend) - Documentation - OpenMRS Wiki, you could surprised about how pretty fast you set up the dev env because you can choose either Tomcat or Jetty as they are all servlet containers…

@dkayiwa @jnsereko i think this needs an update on the wiki. its quite misleading.

i don’t think this is still supported. I last used it way back in 2019. new tools like Docker have simplified the way we setup OpenMRS instances on all platforms.
cc @dkayiwa @ibacher

I tried to install docker and kind of did not succeed that why this one was suggested…when i get a bit more familiar with staff i will sit on it and install.

i had used the same url last year and it worked but the jetty did not run anyway. It had so many errors including issues with versions reason i decided to drop everything and start afresh. Thank you for the new url…gonna try it out. Thank you.

Feel free to edit any instructions that you find out of date or misleading.


I am following the get started as a developer documentation from openMRS wiki while following to set up the openMRS server i got this error while choosing the MYSQL installation method

looking for help to resolve this Thank you :smile:

Which version of MySQL are you using? Or else you can share the command / error log here to understand the failure better.

I don’t had mySQL downloaded .While following the instructions an option poped up on the powershell asking for , Which database would you like to use?: I selected option2 as suggested in the documentation . Here I’m attaching the screenshot for better understanding

Do i need to install mySQL? Because it was not mentioned in the docs

It’s better you install MySQL 5.7 and then go for option 1 as I also faced the same issue previously.

Sure i"ll try that and let you know Thanks :smile:

Advice by my side -: If you’re using windows 11 check whether you’ve MySQL Installer - Community preinstalled. If yes, then continue by that.

Also make sure the version of Mysql you are installing is compatible with one of openmrs you have. I have hear to do things a fresh because of incompatibility. All the best.

I followed the steps from the documentation everything was going fine up to this stage

But as soon as the installation finishes I got this huge error

I don’t have any idea what to do. Looking for help. OS - Windows10, mySql version - 5.7 Thanks :smile:

It happens. You rebuild it again & check.

I tried but still facing the same error :cry:

Well, your sdk has been setup know successfully? Or you’re facing this error while setup? Or else when you run a server you face this issue? Can you elaborate.

The sdk setup was fine it went as expected it displays the message in the end saying server configured successfully . But when i start the server this error appears at port 8080 . I’m following this documentation for setup I’ve downloaded the pre-requisites Java SE, Maven, Docker and Mysql-5.7 Get Started as a Developer - Documentation - OpenMRS Wiki