Fixing the DeleteFormTest in the reference application

Hallo guys I am working on this ticket

I have tried have tried updating the surefire plugins to other versions and the dependences in the pom file but the DeleteFormTest is not running. Here is a copy of the error log.

@dkayiwa @jwnasambu @k.joseph @mozzy @herbert24

Can you please run that test as mvn clean install on command line , if you wish to test it locally feel free to run it via your IDE as junit test, Also be sure to be running on updated branch of distro

By default tests are disabled and so you will still need to pass on a parameter to get them enabled

1 Like

@k.joseph Pass the parameter in the terminal while running mvn or in the test code?

on the command.

I have tried to enable the tests in the command line. I request you to review this log

have you compiled uitestframework already? remembers it’s the master branch?

Also i am trying to clean install but this error

package com.thoughtworks.selenium does not exist is coming up in the UI tests @k.joseph yes

compiling uitestframework should make that available

1 Like

ping me today around at 11am i fix in in a few minutes to unblock you on call

@k.joseph okay

@herbert24 how can i ping you?

@k.joseph I have compiled the uitestframework but the error is persistent.

did you pull changes and are surely using master branches? if so, please copy me here on the commands you are running in their respective order or share your entire command line logs


the compilation of the uiframework

could you try again the commands with option -U


The compilation for the uitestframework is successfull but the compilation for the reference application is still giving me an error.

also, visit your ~/.m2 folder and cross check if your selenium library was rightly downloaded else you could have a devil/corrupted version seating in there

Yes both of them are upto date i had pulled their latest versions and i have done it again and still shows they are upto date

have you tried checking if you have a devil in ~/.m2?