Error on Uitests qa branch using Selenium Testing

Hello Friends, Have been working on quality assurance working on this ticket, and we have been encounting same error as seen here, and some other pull requests here as i was trying to debug this happened to some other friends of mine who are working on quality assurance tickets facing the same error which almost got us blocked for some while :slightly_smiling_face:

Procedures to follow to re produce same error can be found following this link QAFramework Technical documentation(Cucumber-Selenium&Cypress Set up) - Documentation - OpenMRS Wiki, making sure you try to ignore any single test, since this is community priority quality assurance work , your emergency help will be appreciated and keep us moving on well thanks cc @k.joseph @dkayiwa @ibacher @raff

is there anyone facing this among the qa contributors; @kdaud ? etc

You need to be sure travis is running the qa branch @sharif

1 Like

Sorry for late reply, sure am running on qa branch as seen here , and btw seems this happens even when there is no change that has been made

follow the travis config to will realise the parent project isn’t compiled anywhere above

Locally the build plan passes. However, when triggering a commit on the upstream qa branch the ci plan fails. Have just made a pr in respect to the this ticket

I understand this phrase as: When making a pr, ensure that the commit is made against qa branch of the distro. I am positive for correction in respect to the interpretation

Sorry basically parent project is master branch of uitest framework or whole distro refapp! some clarification here thanks

@k.joseph As you can see it here with @kdaud builds its the same error

Going through the error log, it seems the noise is coming from the method clickOnLast(org.openqa.selenium.By) present at Ideally this method was introduced on qa branch and is not present on master But this should not be the cause as I may think

@k.joseph this error continues to appear on qa branch with clickOnLast method, can we try to use any other method incase of clickOnLast ,may be it that might also release us

Have gone through @herbert24 commits against qa branch module in respect to qa technical work and his ci plans are passing. I think we may be missing something obvious. @herbert24 do you have something to share with us on this point.

well am re testing a couple of things and will get back here as requested cc @kdaud @sharif

How fur with testing make sure please you are qa branch thanks

Do you mind sharing pull request that is passing

Have just picked one of them here. Hope @herbert24 will take a look at the review have made in respect to the commit

May be as @herbert24 is looking into the comments on pull requests , i guess some pull requests may pass on travis only and only when that work being done is not related with Page class which will be rare at the moment since we are working with pages and feature files .

I think the ci plan will fail no matter where the work is done as long as a commit is triggered against the qa branch. I am investigating time into this issue to find out the root cause and ASAP will share my opinion. I think @k.joseph is looking into this as well

FYI debugging considers to work on single line of error log per log , if you jump a single line it may be tricky to track unless some one is more experienced in debugging , so i think if that error is handled first we may land on other error log or getting ci to pass

What is your recommendation then

Suggesting that, Since clickOn() have the same functionality with clickOnLast() under the hood , would suggest that we first use clickOn method since it passes both locally and travis, though still wondering why that method failed travis even if its introduced on master branch , hopefully in todays call @k.joseph will clarify on this point, otherwise this blocker is making work not progressing