error in bahmni installation using vagrant and virtualbox

I followed the steps in this link carefully and sucessfully download and installed the rpm , but during the process of starting up the vm ,it encountered an error , network unreachable, Meanwhile i use a very fast 4g internet network and i have all the pre-requisite installed prior to the setup. attached is a screenshot of the error

i closed my command prompt cd into the bahmni folder directory ,tried vagrant ssh , it didn’t work and i ran vagrant up and it says vm is already running but i cant seem to access bahmni environment. please any help or guidance would be appreciated.attached is also a screenshot taken after the initial failure of the vm to establish a remote connection. i am running everything on a windows laptop, there is no external computer or network, everything done on a windows machine.Thanks

Can you please mention the following:

  1. Windows version you are using.
  2. Virtual Box version on your machine.
  3. Vagrant version on your machine.
  4. RAM on your machine.
  5. Free disk space on your machine.

Thanks for the reply. windows 8 virtual box 5.02 vagrant 1.7 8gb ram

50gb free space

Could you please try after upgrading to the latest version of Vagrant and Virtual Box. The latest version of Vagrant is 1.9.1 and Virtual box is 5.1.14.

what of the bahmni rpm . its 4gb of download. what happens to it.does it mean i have to uninstall my virtual box. how can i update vagrant. because installation went smoothly but it refuses start the vm as the images above show.

You can update both – Vagrant and Virtual box, without needing to re-download the Bahmni box.

Basically the Bahmni box is a vagrant box image, which runs on top of Vagrant Software, which in turn runs on top of Virtual Box. So… we are suggesting you to update the Vagrant Software Installation and VirtualBox installation to the version recommended by Sruti. Maybe you can check if its already the same?

The Bahmni Box does not need to be downloaded again if you have already done it once using the vagrant up command. Its stored separately in your machine.

So for the virtual box , all need to do re download a newer version and install. For vagrant when do vagrant up , it search for the latest version and any updates but it says my vagrant is up to date. Thanks

i have updated both and still the same error. please is there any other solution. does bahmni have an iso. that would make installation a whole lot easier.Thanks that would go a long way

Hi @tmlewin,

I think this is because it is not able to find the ssh command in the PATH variable. If you have followed the steps mentioned in wiki, you must of installed “Git”. If so, please run this command (or you can setup it through the UI as well) to set the PATH variable to include “ssh” command.

set PATH=%PATH%;C:\Program Files\Git\usr\bin

Please refer this stackoverflow page for more details.

Bahmni natively only supports CentOS. You can install it on CentOS using the steps mentioned here:

If you don’t have a CentOS machine locally, you can use the Digital Ocean (or equivalent IAAS provider) to install Bahmni on the cloud. Link:

If you want to run it on Windows, then it needs a “Virtual Machine” running CentOS. That is what we have provided with the vagrant machine (which which your machine seems to be struggling). If that isn’t working for you… then you can install your own fresh VM with CentOS v6.x, and install bahmni inside it using the CentOS installation instructions.

Thanks guys for your help . I did a fresh install of everything including an updated version of virtual box. The VM finally ran and loaded cent OS in a pop window. Now am asked to input login and password for cent OS. Please what is login and password for the Os . Secondly now the virtual box is running the rpm, how can access the bahmni app on the browser. Thirdly , what is the possibility of accessing the bahmni web app folder , plan on doing some config tweaks, mind you am running it on a virtual box VM. Thanks

Hi @tmlewin,

  • The username/password combination when you access Bahmni from VM is vagrant/vagrant.
  • The URL to access Bahmni from browser is
  • You can find all the configuration related files at /var/www/bahmni_config/openmrs/apps folder for all the module in Bahmni. Connecting via SSH to the Bahmni server is the easy way to do any configuration/code changes compared to accessing from VM.

To know more about all the Bahmni related services and to navigate to the file system check this wiki page.

You can use putty (from Windows) to connect to the running VM over ssh, and then edit the files. Or use one of the File Editors on Windows which support remote file editing over SSH/SFTP to edit files inside the VM.

@Himabindu Akkinepalli @gsluthra ,Thanks for both your helps mean while when i power up the vm in virtual box and it loads centos and i login using vagrant vagrant. when i access the browser in windows it fails to load. below is the snapshot

hi @tmlewin,

Check what is the ip address the VM got. You can do that with “ifconfig” command after logging into the VM

i did ifconfig and ip is port 2222. i ran it using ip and it still doing waiting and fails to load.

that IP is a local Ip. You need a network IP to access. It should ideally have been If not, then maybe you need to ensure your VM has networking enabled. If you used Vagrant to setup the VM, then the ip specified in Vagrantfile should work.

i used this step . i setup the vm using vagrant. here is my snapshot, when i do nothing works.

Can you also provide the output of the “ifconfig” command? It shows the actual IP addresses assigned. will always work for any machine.

You need to run the “ifconfig” command inside the Centos machine, and not on the windows machine.