Error exporting metadata through metadata sharing module

Hi everyone! I was trying to export metadata from one openmrs platform with the aim of merging concept dictionaries with another openmrs platform. On exporting metadata through metadata sharing module I am getting a lot of errors. I need to know how can I work around this. Metadata error -

I have read some similar posts like CIEL - Error exporting packages - #3 by akanter but what I get is that there are some concepts with duplicate names. But how does this affect the data export aren’t the concepts identified by conceptid?

1 Like

pitiriasis versicolor’ , linfadenitis’,conjuntivitis at├│pica,, meningitis bacteriana, ,are duplicate names in locale ‘es’

However i have failed to reproduce this on qa server or demo server for instance , which platform version or referenceapplication are you running

I am using openmrs 2.0.6 to export metadata but my plan is to import it to 2.3.2 if not possible I will import to 2.0.6. I am not using reference application user interface, I am using legacyiu.

Probably you are running the old CIEL dictionary where these concepts are duplicate, you can update your server by running on 2.3.2 which runs the latest version of CIEL dictionary

I have try to run metadata export on openmrs 2.3.3 with metadata sharing module 1.7.0 and still get the same errors. metadata export error1 - This seems to be like a dead end. Is there any other alternative of merging concept dictionaries between servers other than using metadata sharing module?

If you do not want to fix the validation errors, set the value of the setting/global property named validation.disable to true and try again.

I have disable validation on global property settings and export metadata. I got an error metadata export error2 -

@jerome24 you can look into this reference to see if it can be of help

Thanks but did not help much. I have tried exporting other items and it has run successfully except when I added concept item( event when I try to export concept item alone I get an error). I need to find a solution to solve the error.

Did you restart tomcat after setting that global property to true?

Yes, I did restart tomcat that is why errors have been reduced from 427 to 1 error.

Does it work if you remove the xforms module?

I still get an error after removing xform modules. export metadata rm xform module -

Are you able to reproduce that error on the demo server?

Here is the error from the demo server.

Can you also share the zip that you are trying to import?

I was not importing, I was exporting metadata.

How many concepts are you trying to export? Do you get this error when you export one concept or just a few of them?

I am trying to export concepts like 50,666. I have tried to export a few concepts like 350 and it went successful. I think I will have to figure out a few concepts to export.