Error during OpenMRS installation wizard

Hello everyone,

I am trying to install OpenMRS on my MacBook, however, during the installation wizard I get the following error: “Unable to create the database. The password might be incorrect or the database is not started. ???Error executing sql: create database if not exists ? default character set utf8 - Could not create connection to database server. Attempted reconnect 3 times. Giving up.???”

Can you please advise on what I should do?

thank you projectsundarban

@projectsundarban hope this link helps

@herbert24 We did follow these steps exactly. Unfortunately, we still get the same error.

We would like to implement OpenMRS in a hospital in India, but we have been struck for several days with this error. I hope anyone can help us out…

It might help if you share what exact step you got to when you see that error message (and perhaps what choices you made leading up to that step).

1 Like

For the main part we followed every step of the OpenMRS guide. We also installed all software required by OpenMRS, Tomcat and MySQL.

Can you share the tomcat log at

@projectsundarban , this may work for you.

I remember facing a similar issue a while ago, downgrading my Mysql to the right version worked for me. In the link that I have provided, the versions mentioned are that for an older version of OpenMRS. Based on your platform version, kindly do ensure that you have the correct versions of Mysql, Tomcat etc. installed. If you still face an issue, kindly do paste your logs like Daniel has mentioned.

I tried downgrading everything, still, I get the same error. I downgraded to Java 8u65, Tomcat 8.5.32, MySQL Server 5.6.40 and OpenMRS 2.0.5. I am currently trying to install OpenMRS on a MacBook Pro 10.13.5. Our plan is to configure the network tomorrow and, afterwards, install OpenMRS on a Windows Server 2016. Please find the Tomcat log here: Would it maybe be possible to help us via Teamviewer?

Thank you

What is the exact version of OpenMRS that you are trying to install?

I tried 3 different versions: 2.1.3, 2.0.5 and 2.0.6.

Do a fresh install of 2.1.3 and then share the complete tomcat log.

Which log do you exactly require? I have included “localhost.2018-07-19.log” in the following pastebin link:

Is this as a result of a fresh install of 2.1.3?

Yes I deleted all versions and reinstalled 2.1.3

Is that all that this file has?

Yes, from that file everything is in the pastebin. Should I also add other logs (‘manager’ and ‘catalina’)?

Yes share the contents of the catalina file too.

Ok, please find below the pastebin links to the catalina file and manager file logs respectively. Thank you

Looks like you are running out of memory. Is this of help?