Environment set up

Hello community, I am new on the platform at the environment setting level, guys i need your help: https://pastebin.com/fXXLW6eu

The failure is most likely caused by your internet connection that may not be stable. Ensure to have a stable connection and try again.

@kdaud thanak you but i have try reboot my network but still the error is coming

@wolterbwambale kindly can we meet on this link https://meet.google.com/snr-jbjj-wbm

@wolterbwambale Kindly how far with running this command mvn openmrs-sdk:setup?

@jwnasambu the error is still persistent

Could you outline the steps you have done?

@kdaud the following are the installation and their versions

  1. jdk 1.8 2.maven 3.8.5 3.tomcat 8.5 4.mysql 8.0.29 5.eclipse 6.visual code eiditor

Here are steps so far
1.mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:setup-sdk

2.mvn openmrs-sdk:help

3.mvn openmrs-sdk:setup-sdk -U

4.mvn openmrs-sdk:setup

Was the step above successful?

@kdaud step one to three successfully installed and the error is on step 4 after creating server id, database name ,username and password

Could you share the server side logs via pastebin.com?

From the shared logs

The distribution requires a MySQL database. Please specify database uri (-DdbUri) (default: ‘jdbc:mysql://localhost:3306/@DBNAME@’): open-mrs

Go with the default database url

Please specify database username (-DdbUser) (default: ‘root’): Admin

Is the database username name Admin?, if not go with the default.

Please specify database password (-DdbPassword): Admin123

Here you need to enter the database password which you set during mysql installation. If you didn’t set it then you need to set it up.

Note: Make sure the mysql server is up and running.

1 Like

Kindly forgive but on this step he doesn’t need to enter anything instead just pressing enter.

The database password he is supposed to use the mysql root password.

Thanks @jwnasambu for chipping in, what I shared above was a response to the logs @wolterbwambale shared here which indicates what he entered at those respective steps during the wizard set up.

1 Like

well, after looking at the logs critically, this is my suggestion

If you want to enable remote debugging by default when running the server, specify the port number here (e.g. 1044). Leave blank to disable debugging. (Do not do this on a production server) (default: 'no debugging'): **1044**

The distribution requires a MySQL database. Please specify database uri (-DdbUri) (default: 'jdbc:mysql://localhost:3306/@DBNAME@'): `just press enter`

Please specify database username (-DdbUser) (default: 'root'): `press enter`

Please specify database password (-DdbPassword): `enter the mysql root password`

Note: just incase you have forgotten your database password, you can follow this path to access it On Windows systems:

C:\Documents and Settings\YOURUSERNAME\Application Data\OpenMRS
C:\Windows\system32\config\systemprofile\Application Data\OpenMRS

On Mac OS X or Linux systems:

1 Like

Thank you These worked for me what next

Kindly run mvn openmrs-sdk:run to start the server.

1 Like

@jwnasambu yes it has asked me to choose on the server and displaying one server that i created before