Data Integrity Module Refused to Start

Tags: #<Tag:0x00007f01b8b3de98> #<Tag:0x00007f01b8b3dda8>

Hello Everyone, I have been trying to deploy the data integrity module version 4.4.3 on OpenMRS Standalone Reference App 2.7.0 but the module refused to start. Is there something am doing wrong? https://pastebin.com/uHsfuhWQ

Just tried on Reference App 2.6.0 now am getting the error

groovy.lang.MissingPropertyException: No such property: rule for class: SimpleTemplateScript7

Also help me identify the combinations of modules i need to get this module up and running in my reference app

@brightoibe Have you tried downgrading to Version 4.4.2

2 Likes

Will try right now and get back to you. Thank you @tendomart

Downgraded to 4.4.2 even 4.4.0 still getting the same UI error

UI Framework Error

Root Error

java.lang.NullPointerException: Cannot get property ‘ruleName’ on null object at org.codehaus.groovy.runtime.NullObject.getProperty(NullObject.java:60) at org.codehaus.groovy.runtime.InvokerHelper.getProperty(InvokerHelper.java:172) at org.codehaus.groovy.runtime.callsite.NullCallSite.getProperty(NullCallSite.java:47)

This it the new error am getting;

groovy.lang.MissingPropertyException: No such property: rule for class: SimpleTemplateScript14 at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.unwrap(ScriptBytecodeAdapter.java:53) at org.codehaus.groovy.runtime.callsite.PogoGetPropertySite.getProperty(PogoGetPropertySite.java:52) at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callGroovyObjectGetProperty(AbstractCallSite.java:307)

@brightoibe Please check if these module versions are running Webservices 2.19.0, UIframework 3.11.0 -and the default from Ref App 2.6.x or 2.7.x

@brightoibe can you share the server side log at pastebin.com?

Thank you Sir. Here is the link. https://pastebin.com/T6b2U0MW

Does it still happen when you remove the drugorders module?

I do not have a drug order module Sir.

We really need the data integrity module to work to help us track data quality.

In your stack trace.

org.openmrs.module.drugorders.fragment.controller.DrugordersFragmentController.controller(DrugordersFragmentController.java:36)

Just did another test with a Reference App 2.7.0 Standalone. Link to log file is below

https://pastebin.com/KDhZMpBb

The error it keeps displaying is below;

Caused by: groovy.lang.MissingPropertyException: No such property: rule for class: SimpleTemplateScript13

Sir,

Have done another test and generated another log file just to see it the DrugordersFragmentController.controller error will happen again.

I have attached the line to the pastebin.

Thanks

Does it still happen if you use the latest version of the reference application standalone?

Yes. I tried it on the Reference App 2.9.0 Standalone. I tried the dataintegrity-4.4.2.omod. I was getting error messages.

I will be sending it to you shortly.

Thanks

UI Framework Error

Root Error

groovy.lang.MissingPropertyException: No such property: rule for class: SimpleTemplateScript18 at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.unwrap(ScriptBytecodeAdapter.java:53) at org.codehaus.groovy.runtime.callsite.PogoGetPropertySite.getProperty(PogoGetPropertySite.java:52)