Data Integrity Module Refused to Start

Tags: #<Tag:0x00007f0f2698e180> #<Tag:0x00007f0f2698e018>

The deployment succeeds but when you click it from the front end, you get a UIFramework error. Detailed log file from Reference App Standalone 2.9.0 After deploying dataintegrity 4.4.2 -omod.

https://pastebin.com/kPw1h0wG

Can you share the actual server side log?

Attached is the server log file as requested2019-9-23.txt (167.8 KB)

What does this mean?

When you deploy the module in Reference App 2.7.0 it deploys and starts successfully. When you click on the Data Quality App button it throws a UI framework error on the front page.

This is a bug. Can you create a ticket in the Data Integrity Module JIRA project?

Remember to share the ticket url here.

Ticket created. Link below;

On the ticket, i have attached a compiled module for you to try out.

Am trying it out now. Will update you with feedback.

The Data Integrity Module is starting now but it does not show its “tab” on the home page like other modules (e.g “Register Patient”) on our version of Reference App 2.7.0.

It also hijacks the System Administration tab on the UI framework and leads you to the “OpenMRS Global Map” making it difficult for us to return to legacy interface . What do you think is the cause of this?

Can you share screenshots of that behaviour - it is not very clear to anyone who may want to help you

1 Like

Thank you Sir. I will be sharing the screenshot shotly.

Am still unable to get my data integrity to work. Please need help.

@brightoibe Still waiting for the screenshot of what you see

When I click this, I see this

This error happened on OpenMRS Reference App 2.7.0 using dataintegrity-4.4.2.omod. Am testing dataintegrity-4.4.3-SNAPSHOT.omod. Snapshot coming shortly.

This error happened on OpenMRS Reference App 2.7.0 using dataintegrity-4.4.2.omod. Am testing dataintegrity-4.4.3-SNAPSHOT.omod. Snapshot coming shortly.

It would help to share the server side log too via something like pastebin.com

This is a snapshot of the outcome of testing the dataintegrity-4.4.3-SNAPSHOT.omod on OpenMRS Reference App 2.7.0 Standalone.

When I click here on the blue circle;

I get this page;

image

Notice that the System Administration button has disappered. I can’t get the interface where i can configure new data integrity rules.