Creating a new user Acount on mdsBuilder server

Tags: #<Tag:0x00007f75110d0858>

Am folowing this document here , and am supposed to do some work in the mdsBuilder server. I have a valid ssh key and can login in into the serverside.
Step 2 requires loging into the server (as a client) via the login page ,and i have no login credentials. How is the user account supposed to be created ?

I Created case at help desk , and i was told to

Can you raise a topic in talk and ask clarification on how your user in mdsBuilder is supposed to be created?

cc @dkayiwa @raff @cintiadr

cc @dkayiwa @cintiadr Any updates on how i could get a user account on the mdsBuilder server, ? i need to be able to

  • Update Metadata Sharing packages and also
  • Export concepts using data exchange to preserve IDs for later updates of CIEL.

For full context, I asked this question. https://wiki.openmrs.org/display/ISM/OpenMRS+environments

mdsbuilder has no clear owner, I have no idea who should have access to it (or if we should grant access to every release manager). That’s not something that was asked before, so I’d like clarification.

What’s the process?

@c.antwi or @dkayiwa, would you know anything about this?

@cintiadr are you asking for whether every release manager should be granted access?

Yes, @dkayiwa

And if the answer is yes, should it be raised on the helpdesk? If that’s the case, it would be nice to document the permissions to grant (so otherw could do too)

1 Like

hi @cintiadr , can i now get the credentials , i need to get the above done by this week at latest. we are already behind time

Account created and sent to you via a private message.

1 Like

Thanks @dkayiwa

Hi @cintiadr , i followed the steps here to Update CIEL on the mdsbuilder to the latest version , and ofcourse i was replacing the sql dump in the example below with the latest version i downloaded from drop box

`scp`   `openmrs_concepts_2.0_20181012.sql.zip <username>@mdsbuilder.openmrs.org:` `/tmp/openmrs_concepts_2` `.0_20181012.sql.zip`

`ssh`   `<username>@mdsbuilder.openmrs.org`

`cd`   `/tmp`

`unzip openmrs_concepts_2.0_20181012.sql.zip`

`sudo`   `-i`

`cd`   `/root/docker/mdsbuilder`

`docker ` `cp`   `/tmp/openmrs_concepts_2` `.0_20181012.sql mdsbuilder_db_1:` `/tmp/`

`docker ` `exec`   `-it mdsbuilder_db_1 ` `/bin/bash`

`# copy as is, do not attempt to replace it`

`mysql -u ${MYSQL_USER} -p${MYSQL_PASSWORD} ${MYSQL_DATABASE} < ` `/tmp/openmrs_concepts_2` `.0_20181012.sql`

`exit`

Am trying to test out the Concept dictionary on the mdsBuilder server by searching a concept, to see whether it was updated with the Latest CIEL that i uploaded. However every concept i search out , i get this error

Error while attempting to find concepts - could not extract ResultSet

.
i followed the script step by step. and i can check and see that the sql dump i uploaded exists in the /tmp directory

i have downloaded the concept dictionary from the mdsBuilder server and its empty. i there any command that needs to get updated in the above script for the sql file to be loaded in the database ?.

And from the above issue , i cant update metadata sharing packages for the Reference Application Concepts. i get this error on creating a new version of the packge https://pastebin.com/rvmhFuan

Actually , when i query the databse directly via command line , using the credentaials here

, i can see the database is updated with the latest CIEL that i have uploaded.
However i cant understand why i cant see a single concept when i search it via the UI

Has the concept dictionary been indexed?

Hi @burke , are you talking about this ?

i seem not able to see this functionality here

Administration -> Update Concept Index.

i tried to rebuild the search index

Administration >> search index
but i still get the same issue when searching for a concept via UI

here are the Logs on trying torebuild search index https://pastebin.com/2k7Vb8N5

and this is the server log when i try to search for a concept

|ERROR - SqlExceptionHelper.logExceptions(146) |2019-10-18 14:17:49,944| Unknown column 'concept0_1_.precise' in 'field list'|
| --- | --- | --- |
|ERROR - SqlExceptionHelper.logExceptions(146) |2019-10-18 14:17:49,941| Unknown column 'concept0_1_.precise' in 'field list'|
|ERROR - SqlExceptionHelper.logExceptions(146) |2019-10-18 14:17:49,939| Unknown column 'concept0_1_.precise' in 'field list'|
|ERROR - SqlExceptionHelper.logExceptions(146) |2019-10-18 14:17:49,938| Unknown column 'concept0_1_.precise' in 'field list'|

What is the name of the CIEL file that you used to update the database?

openmrs_concepts_2.2_20190701.sql

i downloaded it from openrs account on drop box

That is the cause of the problem. mdsbuilder is running platform 2.0.6 instead of 2.2

So you need to use the CIEL file for platform 2.0.6

1 Like

here are the versions updated

1.6.6, 1.9.9, 1.10.2, 1.11.4 and 2.0, 2.1 and 2.2!

So i instead update with this openmrs_concepts_2.0_20190701.sql ??

Yes that is the one.

1 Like