Coreapps module "it crashes when webpack is compiling"

Hello, I wanted to make some UI adjustments on the patient page on local machine so i have forked and cloned the coreapps module and i made “mvn clean install” then modify the patient HTML page and made “mvn openmrs-sdk:watch”, so i refreshed(crtl + f5) and the page stayed the same.

Do this module need to build always after some UI changes? any can help me what im doing wrong


For what it is worth I have tried to use this SDK feature without success! I always have to build. I didn’t do enough troubleshooting to see whether there was something I am doing wrong though, so it might a mistake on my part.

I haven’t used this feature in a long time either, but just to check, after doing :watch you restarted the sdk server, right?

@willa @darius , ty for your fast answer. But even after i build the coreapps module, i try to refresh(crtl + f5) and the page stay the same, Do i need to update the module on the page localhost:8090/openmrs/admin/modules/module.list?

Solved: the problem was not running the command line as Admin.

After a normal reboot, now the server it get stuck on starting the server, even on running as Admin log here.

Any one had this problem or know how to solve it? Maybe @dkayiwa knows about this

PS: since the main issue is solved, im not sure if should create another topic about this second issue

@meizzz does it still get stuck when you do not watch any module?

@dkayiwa, When “watch” the module it gets stuck on server running or build the coreapps module like the pastebin that i putted on the other day. But when i unwatch both(server or build the module) they run okay, but the problem is that the changes i wanted to make on Coreapps module doesn’t appear,even when i refresh(ctrl + f5)

Any suggestions?

@dkayiwa, maybe @wyclif or @raff know anything whats going on

What kind of changes are they that do not appear? Can you tell us the class where these changes are?

@dkayiwa, i just made some view changes on .gsp files. The first problem is that i cant build the module or run the server while watch the coreapps module. Solution for this is to make clean install for each change i make, but ofc that’s not a reasonable solution, i expect to later make changes. Any solution for this?

Can i look at the log you get from the time you execute the sdk run command?

@dkayiwa with watching the core apps here

Thanks for the help, btw

Do you run this with an internet connection?

yeah i run with internet

Do you get the same behaviour when you try watch another module like this one?

For GSP files, these are automatically updated when the module is watched. The Javascript files are another issue since they are compiled with npm etc, so you need to stop and start the server, which recompiles them

@dkayiwa , everything normal if i try to watch and build that module. If @ssmusoke says its true and not a chance a ill spent a lot of time on reinstalling the coreapps and restart a the server

@meizzz does that mean your interest is in watching JavaScript files?

@dkayiwa i want to edit one page off the coreapps with my service that i created on my module

I tried watching a branch new coreapps module without any local changes and my .gsp and java controller class changes were hot reloaded as expected, without requiring me to recompile and redeploy. That is, on just saving, the changes were reflected in the UI on refreshing the browser.