Core Apps patient page look and feel different on desktop browsers

Tags: #<Tag:0x00007f29a16c5850> #<Tag:0x00007f29a16c55a8> #<Tag:0x00007f29a16c5300>

@ssmusoke and @ayesh, is the safe way out of this to use Core Apps 1.23.0?

There are more participating modules I guess, and that one has to involve all these. @ayesh could you also list those modules and their versions here as well?

@ruhanga the list is below

  1. Core Apps
  2. UI Commons
  3. Reference Application Module
  4. App UI
  5. Admin UI
  6. Appointment Scheduling UI
  7. Registration App
  8. Chart Search

Each of these has a release without Bootstrap integration as we keep moving forward and fixing those issue that can be found

2 Likes

@mksd sorry I had missed this - yes that is the safe way out of this

1 Like

Hi @ssmusoke @ruhanga @mksd Sorry for the late reply.Yes these are the modules as stephe mentioned.

1 Like

Thanks @ssmusoke, that’s useful. Btw I think the next iteration for Admin UI should have been 1.3.0-SNAPSHOT (and not 1.2.6-SNAPSHOT.)

Looks like Chart Search did let a Bootstrap commit go through prior to being released? Is that so @ayesh?

2 Likes

@mksd I have opened a PR for adminui will be sending another for chart search to revert the changes, release then add the bootstrap ones. Apologies for the inconveniences caused

1 Like

@dkayiwa How do you advise I approach to resetting chart search to this commit https://github.com/openmrs/openmrs-module-chartsearch/commit/2c9828738669341a486bd1f904de38c245b0f1fc so that I can release a new version before applying bootstrap changes

1 Like

Hi @mksd , @ssmusoke , @ruhanga

To keep u guys updated. Still the changes after fix not visible in qa-ref app server becuase ref-app-distro ci is build failing(Some selenium test cases are failing).I am still working on patient dashbaord it’s almost finished after that will be having a look at the issue on the ci it self.

1 Like

Thanks @ayesh for the hard work. You could have also noticed the issue bellow was more specific to changes in the Appui module. Let’s wait and seen when the ci builds are fixed.

Hi @ruhanga

Yes it is because of the jquery file conflicts.I actually pushed the code for this fix to the git hub and the PR was also sent but there are these build failures

https://ci.openmrs.org/browse/REFAPP-OMODDISTRO-INTTESTS-9035/log

@mksd @ruhanga

Now in the qa ref app most of the changes have applied. https://qa-refapp.openmrs.org/openmrs/login.htm

But I see an issue in the attachment upload module hmm nothing shown there will address it today.

Hi @ayesh, I seem to get a UI Framework error for the qa ref app on my end. Are you able to login?

Yes I tried in incognito as well to make sure the cache it works :thinking: https://qa-refapp.openmrs.org/openmrs/login.htm

1 Like

And @mksd, @dkayiwa , @ssmusoke , @ruhanga

Is the demo server (https://demo.openmrs.org/openmrs/coreapps/clinicianfacing/patient.page?patientId=8180149e-5f36-4ad6-b5a9-c7b12a6e7ec9) deployed with latest release or latest changes.

I only have an idea about the qa-ref app that’s why ?

@ayesh, just extending an issue with the registration app here. You may have noticed the difference on the navigation section/subsections, I mean the green checks as one moves through the different sections while registering a patient look a little different.

Demo

QA Ref App

Have you fixed this somewhere?

Hi @ruhanga

Nope, I have not fixed it. Btw will work in today itself.

Btw can u let me know this

Is the demo server (https://demo.openmrs.org/openmrs/coreapps/clinicianfacing/patient.page?patientId=8180149e-5f36-4ad6-b5a9-c7b12a6e7ec9) deployed with the latest release or latest changes?

I only have an idea about the qa-ref app

Because in demo serve also the attachment page is not working.Seems like few latest changes are there in the attachment module so want to make sure

And yes please let me know these sort of errors when you found them out.Major issues like popup’s homepage look and feel, pateint.page drop downs are fixed.

Will take a look on issues like this on the next few days

cc :- @ssmusoke

No, the demo server relies on more stable versions of modules.

The attachments module version on the QA Ref App may need to be bumped to the SNAPSHOT version since it has gone through some change during this GSoC season. cc: @mksd

@ayesh the buttons on the home page look a bit flattish. Is it easy to make them look like the original ones (which to me looked better)? Or am i just old fashioned. :smile:

1 Like