Cashier module process, post bill & print issues

hello, I’m new here and to openmrs; but I’ve gotten a hang of it and really like it. I’m an implementer.

i installed the enterprise ver. 2.3… and cashier module ver. 4.0 ref. application ver. 2.10. everything seems to be working fine except for some aspects of the cashier module; create new Bill (process payments, post bill and post & print). The save button works as expected, but the other buttons return an error:status on class org.openmrs.module.openmrs… on the screen. pls i need help with that

1 Like

@ssmusoke, @mksd, @dkayiwa, @ibacher kindly take a look and give advice on this

1 Like

@yusufny you can share the error logs here

Thanks for the response. I couldn’t get the error logs (I’m a newbie); so I attached an image of the screen with the error message. Hopelly that will help

@yusufny, Could you try to give some descriptions of what you were trying to do , such that we can also reproduce the same, to find out the error like the screen shot provided thanks

Hello @sharif, I’ve setup the inventory right. Created a trial item in the name ‘test’, and want to try selling this item. That was when I discovered that only the SAVE works fine (of which would reflect the payment as pending). All the other buttons return same error. I hope this is of any help.

1 Like

Perhaps @insiderish or @ibewes could take a quick look?


Or any one else from @BandaHealth

Hey Yusuf,

It would help if you can post your logs.


Morning from here folk, sorry it took too long, was away a bit. here goes the log. thanks localhost_access_log.2020-07-09.txt (65.0 KB)

@yusufny to make others lives easier, don’t get them to download a file, use a pastebin:

thanks for the response, I’ve pasted the log in the paste bin. couldn’t find the submit button on your link (@mksd) so I used this link [] provided by @gcliff earlier on; hope it’ll make for it. screen shot the dpaste page. ScreenShot_20200709192918|690x407

ok, thanks for the direction. I’ve done it

@yusufny you’ll need to share here the URL to the paste after clicking on that button. Just copy it from your browser address bar before sharing it here.

morning, thanks (@mksd). … learning every moment . here goes the url:

1 Like

Got same error. Was this ever resolved? Thanks

As you can follow above, it would be great to share the log using paste site.

The original poster posted the link for the log here . I was just wondering if someone had provided a solution with to him privately.

Hello folks, any updates yet? thanks in advance