Can't deploy openmrs war file on tomcat 8 (Solved)

When i press the “deploy” button om tomcat’s interface… It starts uploading till 2% then gives me this page:

I’m using Tomcat 8.0.50, MySQL 5.5.46, Java 8

What am I doing wrong?

Can you share the server log as a pastebin link?

1 Like


Does this step still apply to tomcat 8?

I think you need to use MySQL 5.6 and above, and this step is applicable.

1 Like

You didn’t mention a version of openmrs you are trying to deploy, if it is 2.x.x then you should change a maximum file size to deploy on web.xml as mentioned in this document.web.xml.docx (46.1 KB)

1 Like

where can I find the web.xml file? cause in web.xml in C:\Program Files\Apache Software Foundation\Tomcat 8.0\conf I can’t find the “multipart-config” tag

What kind of server are using?

If you are deploying in your computer then try to make changes in the context.xml, web.xml and tomcat-users.xml files as shown in this document changes.docx (63.8 KB)

1 Like

Instructions in the web.xml.docx applies for linux server.

1 Like

windows 7 computer would you recommend linux?

I made all the changes in changes.docx and installed mysql 5.6/ still doesn’t work. I tried deploying Openmrs.war 1.9 and it works perfectly. This makes me wonder how I can change the maximum file size to deploy.

Update: the problem was solved by increasing the maximum file size to deploy on tomcat 8 by editing Web.xml in the directory: C:\Program Files\Apache Software Foundation\Tomcat 8.0\webapps\manager\WEB-INF changes were made following instructions in the following file: web.xml.docx (46.1 KB)

Thank you @jmkumbo