can't acces to openmrs

hello everyone…I was uploading a module when I had this error " HTTP Status 500 - Request processing failed; nested exception is org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 33 in XML document from URL [jar:file:/C:/Users/SOLITIONS%20%20PC_01/openmrs/SOUG/.openmrs-lib-cache/emrapi/lib/emrapi-api-1.27.0.jar!/moduleApplicationContext.xml] is invalid; nested exception is org.xml.sax.SAXParseException; lineNumber: 33; columnNumber: 46; cvc-complex-type.3.2.2: Attribute ‘local’ is not allowed to appear in element ‘ref’ "

I clicked on the back button, I had this " HTTP Status 500 - BeanFactory not initialized or already closed - call ‘refresh’ before accessing beans via the ApplicationContext" I tried to open a new session again but i got always the same mistake.

someone help me please!

HI @dlector,

You can just restart the OpenMRS server.

@dlector look into your ApplicationContex configs, if after restarting your server as @vankineenitawrun advised it still continues

Have you tried to restart the server as suggested?

yes @herbert24 @gcliff … now, i have this https://pastebin.com/WvmSbGmL

Which platform version are you running? Ensure all modules are updated to run on that platform version. You can delete all modules in C:\Users…\OpenMRS\modules and try run again.

2.1.4… delete all modules in the server ?

Just ensure all the modules are updated. Yes you can delete all modules and install a fresh.

how can i know if they are updated?

if I delete them all , there is a way to get them all together? like a command to install news?

This link https://wiki.openmrs.org/display/RES/Reference+Application+2.9+Release+Issue+Tracking has all modules with the version updated for RefApp 2.9.0 running on 2.1 4 platform

https://wiki.openmrs.org/display/docs/OpenMRS+SDK#OpenMRSSDK-Settingupservers will guide you.

all modules are up to date but i miss 2or 3. it can pose problem?

Which modules are missing? Yes some modules dependent on the others to run.

UI Test Framework, Name Phonetics

@jwnasambu in this case ,i have to setup openmrs again?

Kindly install the missing modules then run the server again. This is the guide https://wiki.openmrs.org/display/docs/OpenMRS+SDK#OpenMRSSDK-Settingupservers

@jwnasambu I deleted the module I uploaded, I installed Namephonetics (I could not find the omod of uitestframework ) and it worked. Thankyou

Sorry about it. I meant delete and install afresh all the modules and the link I send you was to guide you.